IBM Security i2

Expand all | Collapse all

iBase - Link Count Discrepancy

  • 1.  iBase - Link Count Discrepancy

    Posted 9 days ago
    There is a discrepancy when I view the Links associated with an Entity. In one example it indicates 4 telephone links to a Person Entity, but only displays 2 links to telephones. Does anyone know how to correct this? Thanks.

    ------------------------------
    Manny San Pedro
    ------------------------------


  • 2.  RE: iBase - Link Count Discrepancy

    Posted 9 days ago
    Hi

    i think I need a bit more information to help understand. So how are you viewing the links? An iBase Link Chart, the Links dialog or are you charting into Analyst's Notebook? If you could explain a little more we may be able to help - my initial thoughts are you are either writing queries with slightly different settings - or are setting different Association and Timeline options when charting to Analyst's Notebook. A few screen shots showing the differences you are getting might help us.

    Cheers, Mark

    ------------------------------
    Mark Fleet
    ------------------------------



  • 3.  RE: iBase - Link Count Discrepancy

    Posted 8 days ago
    Thanks, Mark. Here's a screenshot of the links I am referring to. 
    Count in the Link End Summary indicates a total of 4 links (2 links for each of phone number). The list of the Links below display only 2 links (1 for each phone number).


    ------------------------------
    Manny San Pedro
    ------------------------------



  • 4.  RE: iBase - Link Count Discrepancy

    Posted 8 days ago
    Edited by Simon Griffiths 8 days ago
    Are you using SCC (security classification codes)? If so do the "missing" links have a more restrictive SCC value than the link ends?

    For example:

    Joe Bloggs (Low)  -- Subscriber (High) -- 555 1212 (Low)

    Also, which version of iBase is this?

    ------------------------------
    Simon Griffiths
    ------------------------------



  • 5.  RE: iBase - Link Count Discrepancy

    Posted 8 days ago

    In a situation like this I would always open the database in iBase designer and use Tools > Database Administration > "Schema integrity check" and the "Link Integrity check". Out of experience: on the link integrity check, when the screen show an empty screen, it means all is well. I have been waiting for a long time while nothing happens, but this tool actually shows an empty screen when there is nothing to report.



    ------------------------------
    Jan-Willem Lapoutre
    Senior software developer
    DataExpert b.v.
    Veenendaal
    ------------------------------