IBM Security Verify

  • 1.  ISIM ACL: Salesforce Service does not show for Type

    Posted Thu October 21, 2021 01:40 PM
    Hi,

    I've imported/setup a new Salesforce adapter in ISIM v.6.0.0.23. Recon, new accounts, etc are working fine.
    I'm running into an issue where I'm trying to create a new ACI to basically restrict everyone but people in the "requestors" group to request new Salesforce account.
    When I create a new ACI, the Protection Category is Account and when I click on the Type dropdown Salesforce Account type doesn't show up in the list.

    Am I missing something here?


    ------------------------------
    Tim TamDude
    ------------------------------


  • 2.  RE: ISIM ACL: Salesforce Service does not show for Type
    Best Answer

    Posted Fri October 22, 2021 04:54 PM
    There is a problem in the adapter profile - more specifically in the CustomLabels.properties...
    If you unpack the SalesforceProfile.jar and open the CustomLabels.properties you will near the top see the following lines :
    ....
    erSalesforceService=Service Objectclass
    erSalesforceAccount=Account Objectclass
    SalesforceProfile=Salesforce Service
    SalesforceAccount=Salesforce Account
    ....​

    The erSalesforceAccount value is what is displayed in the ACI account type. Correct the the CustomLabels.properties file to have the account/service values to be the same as those given on the 2 next labels i.e. :

    ....
    erSalesforceService=Salesforce Service
    erSalesforceAccount=Salesforce Account
    SalesforceProfile=Salesforce Service
    SalesforceAccount=Salesforce Account
    ....​

    Rebuild the profile and re-import and you should see the correct values in the ACIs....



    ------------------------------
    Franz Wolfhagen
    IAM Technical Architect for Europe - Certified Consulting IT Specialist
    IBM Security Expert Labs
    ------------------------------



  • 3.  RE: ISIM ACL: Salesforce Service does not show for Type

    Posted Fri October 22, 2021 08:13 PM
    Thanks for the response Franz, I will try that Monday and respond back! Have a good weekend.

    ------------------------------
    Tim TamDude
    ------------------------------



  • 4.  RE: ISIM ACL: Salesforce Service does not show for Type

    Posted Tue October 26, 2021 03:17 AM
    I just got the confirmation from our development that this IS a bug and will be fixed :-)
    I have no idea of how long it will take - but I assume that we should see it within the next release cycle.

    ------------------------------
    Franz Wolfhagen
    IAM Technical Architect for Europe - Certified Consulting IT Specialist
    IBM Security Expert Labs
    ------------------------------



  • 5.  RE: ISIM ACL: Salesforce Service does not show for Type

    Posted Wed October 27, 2021 02:14 AM
    Ha! I hope so and at the same time realize that the Salesforce api that is officially supported right now (v33) will be deprecated real soon as well. 

    Cheers!

    ------------------------------
    Tim TamDude
    ------------------------------



  • 6.  RE: ISIM ACL: Salesforce Service does not show for Type

    Posted Wed October 27, 2021 02:11 AM
    Hi Franz! Thank you for your response and follow-up. I followed your instructions and the SalesForce Account shows up and is an object I can create/apply acl's to.

    I appreciate the assistance while I was waiting for the customer to approve my customer number access request to open a PMR on the issue 😁

    Thanks again for the help.

    ------------------------------
    Tim TamDude
    ------------------------------