IBM Security i2

Expand all | Collapse all

IBM i2 iBase login issue

  • 1.  IBM i2 iBase login issue

    Posted Thu July 29, 2021 01:22 PM
    Does anyone encounter issues login in to iBase using a share drive.  One of our client encounter that issue.  Here are the screenshot detailing the issue with comments.
    1. Upon opening iBase 9, the typical default pop-up appears and prompts you to open the last opened database:
    2. After clicking "Ok" and inputting our login credentials, the following error pops-up. Notice that both locations detailed are the exact same (i.e. security file location):
    1. After clicking "Ok" on the error message (we logged in to the security file at this point, but no database is open) and going to "File", we see both "locations" of the database (both are the same, one just the name "Z:" for the shared drive as opposed to its full detailed location). After clicking on one and the other (always getting the same error message), at one point, the database actually does open (the number of times varies, and the location that will actually open does as well: this time took about five back-and-forth, and the "ent" one finally opened).

     
    If you have any ideas, please let me know so we can have a look at the issue.

    Thank you.

    Eric.



    ------------------------------
    [Eric] [Niclaes]
    Sgt (Ret) CD2
    [IBM i2 specialist]
    [Necando Solutions Inc]
    [Montreal] [QC]
    [514-360-4000 Ext 625]
    Cell: 438-821-2402
    ------------------------------


  • 2.  RE: IBM i2 iBase login issue

    Posted Thu July 29, 2021 01:50 PM
    Edited by Linda Miyoshi Thu July 29, 2021 01:52 PM
    Hi Eric,

    I don't believe I've ever seen it where it references the exact same file in both places in that 2nd message.  Curious!
    Many customers do use network drives.  I'm glad your customer is able to get in eventually, but we should definitely get to the bottom of it.

    Maybe someone here has some ideas, but if you're able to open a Support Case at https://ibm.com/mysupport , we could chase it that way.  We can get more details to try to replicate it (which version of v9 is it?  Did the .ids or .idb move prior to this?)  I wonder if it's related to the fact that sometimes it's referenced by the Z: drive and sometimes by the network address.

    Cheers,
    Linda

    ------------------------------
    Linda Miyoshi
    ------------------------------



  • 3.  RE: IBM i2 iBase login issue

    Posted Fri July 30, 2021 04:35 AM

    Hello Eric

    I have seen similar before.  This was in a W8.1 OS using iBase v8.9.11 - it was refusing to recognise the network server when mapped to a drive letter (e.g. I:\) but would let the user in if they typed the full server-path out longhand into the Open dialogue box e.g. \\dummydrive001\iBase.  I know this happened to at least 4 of our users because they made contact with me to help them get it working again.

    TBH I wasn't even thinking the iBase software was the issue, as our network stability at that time could be at best described as "flaky".  The software had been running fine on that platform for more than 18 months, so a new network / OS user profile issue seemed more likely.  The solution I discovered was to get the user to disconnect/forget the mapped server, reboot and then remap the server-path to the same letter.  iBase user history then did still show the same database twice - as per your last screenshot.

    We're in the process of moving our users across to W10 OS on a new network infrastructure.  We're still running v8.9.11 until all users have migrated and then we're going to a v9 build. So far, nobody has complained about this scenario happening


    I was hoping that the recoding work undertaken for the v9 release may have finally fixed a similar login 'frustration' (it may not be a bug but a deliberate design, though not one the users like) which I first discussed with i2 staff back in late 2012/early 2013. If a user has access to more than one database, with different .ids files in different folders, iBase refuses to switch between databases unless you log in to the .ids first.

    To clarify, let's say I have access to Database A and Database B.  They are in different folders with different .ids files.
    - Yesterday I used Database A.  I close iBase down at the end of the day.
    - Today I want to use Database B.  When I open iBase, it offers to open Database A for me as the Last Used.  I press Cancel.
    - I then use Open... and navigate to the folder hosting Database B and point to the .idb file.
    - I will then get an error message that the security file is incorrect.  Rather than looking at the .ids that is in the same folder as the .idb for Database B, iBase will continue looking at the security file for Database A, because that's the last one used.  The only workaround is to run the Login process first, navigate to the Database B folder to find the .ids then run Open database.

    Some Developers may say that this is a more sensible way to design the security, but it is a less pleasant user experience.  Not every Crime Analyst is a confident computer-user; many of my colleagues are brilliant at their role but become flummoxed by various computer error messages they receive when software doesn't work nicely.  iBase is merely a tool to obtain the data they need for their real skills, and the user experience should be the key.  When people find a system confusing or frustrating, they go look for alternative ways to get the same data. 

    I hope the whole login/open process is tidied up in a future release.


    Ant



    ------------------------------
    Anthony Patamia
    ------------------------------



  • 4.  RE: IBM i2 iBase login issue

    Posted Fri July 30, 2021 08:21 AM
    Anthony and Linda.

    Thank you  both for your answers, I will get back to my client are related your comments.

    Best regards,

    Eric.

    ------------------------------
    [Eric] [Niclaes]
    Sgt (Ret) CD2
    [IBM i2 specialist]
    [Necando Solutions Inc]
    [Montreal] [QC]
    [514-360-4000 Ext 625]
    Cell: 438-821-2402
    ------------------------------