IBM Security QRadar

Expand all | Collapse all

Python 3 EOL

  • 1.  Python 3 EOL

    Posted Tue October 01, 2019 04:14 AM

    Hello Everyone,

    The end of this year, will also mean the end of Python 2.7
    QRadar works fully on Python 2.7 and has as far as I know zero support für 3.x
    Does anyone know what IBM will do about this?

    We don't have much time left this year to update, and I would like to have a little bit of a heads up.




    ------------------------------
    Kind Regards,

    Linus
    ------------------------------


  • 2.  RE: Python 3 EOL

    Posted Wed October 02, 2019 11:54 AM
    Hi, In the next release of QRadar 7.4 we hope to upgrade Redhat to 7.7 which will include Python 3 by default. The QRadar team will also include Python 2 in this release. We'll support both versions as we allow teams within QRadar to move over to the Python 3 codebase. No decision has been made yet on when we will fully deprecate Python 2.

    ------------------------------
    SHANE LUNDY
    ------------------------------



  • 3.  RE: Python 3 EOL

    Posted Thu October 08, 2020 10:02 AM
    Hi Guys,
    When do you think QRadar with python 3 will be available?

    Is there a beta version i can try if that is available now?

    Thanks,
    Jabez.

    ------------------------------
    Jabez Daniel
    ------------------------------



  • 4.  RE: Python 3 EOL

    Posted Fri October 09, 2020 08:37 AM
    Hi, Python3 was put in 7.4.1 GA and backported to 7.3.3 FP5. It has no supporting libraries installed yet but the runtime is there. 
    Both of these releases are available to download.

    Thanks

    ------------------------------
    SHANE LUNDY
    ------------------------------