IBM Security QRadar

Expand all | Collapse all

New iso install on AWS instance fails (both 7.3.2 or 7.4)

  • 1.  New iso install on AWS instance fails (both 7.3.2 or 7.4)

    Posted Thu September 03, 2020 01:06 PM
    Edited by Jason Meridth Thu September 03, 2020 01:11 PM

    NOTE: We need a 7.3.2 and 7.4 instance each up and running to support new and old customers.  "Just upgrade" won't be a sufficient answer. :)

    AWS Instance AMI is ami-28e07e50 (RHEL-7.5_HVM_GA-20180322-x86_64-1-Hourly2-GP2)

    We've tried installs with both 7.3.2 and 7.4 ISO files:

    7.3.2: Rhe764QRadar7_3_2_20190201201121.stable-7-3-2.iso
    7.4: Rhe764QRadar2020_7_0_20200707131804.stable-2020-07.iso

    Running

    sudo /media/cdrom/setup

    it fails on

    """

    --> Finished Dependency Resolution

    Error: Package: 1:grub2-efi-aa64-modules-2.02-0.80.el7.noarch (local)

               Requires: grub2-common = 1:2.02-0.80.el7

               Installed: 1:grub2-common-2.02-0.86.el7_8.noarch (@rhui-rhel-7-server-rhui-rpms)

                   grub2-common = 1:2.02-0.86.el7_8

               Available: 1:grub2-common-2.02-0.64.el7.noarch (rhel-7-server-rhui-rpms)

                   grub2-common = 1:2.02-0.64.el7

               Available: 1:grub2-common-2.02-0.65.el7_4.2.noarch (rhel-7-server-rhui-rpms)

                   grub2-common = 1:2.02-0.65.el7_4.2

               Available: 1:grub2-common-2.02-0.76.el7.noarch (rhel-7-server-rhui-rpms)

                   grub2-common = 1:2.02-0.76.el7

               Available: 1:grub2-common-2.02-0.76.el7.1.noarch (rhel-7-server-rhui-rpms)

                   grub2-common = 1:2.02-0.76.el7.1

               Available: 1:grub2-common-2.02-0.80.el7.noarch (local)

                   grub2-common = 1:2.02-0.80.el7

               Available: 1:grub2-common-2.02-0.81.el7.noarch (rhel-7-server-rhui-rpms)

                   grub2-common = 1:2.02-0.81.el7

    You could try using --skip-broken to work around the problem

    You could try running: rpm -Va --nofiles --nodigest

    ERROR: Yum operation 'Installing new RPMs' failed!


    """

    We are looking if we have a way to do --skip-broken but we don't know what that will do. Re-running

    sudo /media/cdrom/setup

    results in

    """

    Initializing...

    Starting setup session in screen

    WARNING: No build_version file, but found QRadar files.

    Getting version from RPMS: adminconsole assetprofiler autoupdate bbperf content-management-toolkit customaction-chrootjail datanode dbfiles ha hostcontext ibm-si-mks imq pcidashboards performance_monitor qbase.

    ERROR: Sorry, upgrades not supported on this release!

              (see log /var/log/setup-2020.7.0.20200707131804/qradar_setup.log for further details or use -h for help)

    Press enter to close screen


    """


    Any ideas or help is greatly appreciated.



    ------------------------------
    Jason Meridth
    ------------------------------


  • 2.  RE: New iso install on AWS instance fails (both 7.3.2 or 7.4)

    Posted Fri September 04, 2020 08:49 AM
    Hi Jason,
    The supported methodology to install in AWS is using the marketplace images: https://aws.amazon.com/marketplace/search/results?x=0&y=0&searchTerms=qradar+ibm
    As you rightly mentioned, The current supported method is to use the highest version of the images and upgraded. Instruction Installations are provided in the url associated with the image.
    Thanks and Regards.
    Sree

    ------------------------------
    SREE ANANTHASAYANAM
    ------------------------------



  • 3.  RE: New iso install on AWS instance fails (both 7.3.2 or 7.4)

    Posted Fri September 04, 2020 11:50 AM
    @SREE ANANTHASAYANAM Thank you very much for the suggestion.  That worked.  Now I'm curious how we ever got it working with the ISO installations manually. :)

    Cheers,
    Jason​

    ------------------------------
    Jason Meridth
    ------------------------------