QRadar XDR

  • 1.  IBM QRadar Community Edition How to patch

    Posted Mon August 30, 2021 06:04 AM
    HI 

    I DOWNLOAD THE  IBM QRadar Community Edition 7.3.3 1.0 GA

    https://www.ibm.com/community/qradar/ce/

    and how to patch this version 

    i think update this version to Fixpack 9

    ------------------------------
    Hung-Ting Chou
    ------------------------------


  • 2.  RE: IBM QRadar Community Edition How to patch

    Posted Tue August 31, 2021 01:11 PM
    QRadar Community Edition is a unique build and cannot be upgrade/patched. You must complete a new install of QRadar Community Edition when a new version is available.

    ------------------------------
    Jonathan Pechta
    QRadar Support Content Lead
    Support forums: ibm.biz/qradarforums
    jonathan.pechta1@ibm.com
    ------------------------------



  • 3.  RE: IBM QRadar Community Edition How to patch

    Posted Wed September 01, 2021 09:26 AM
    Hi Jonathan Pechta,
    I have the same question, too.

    When I go to QRadar Community Edition download page, it show QRadarCE733GA_v1_0.ova only.
    I try to develop using "QRadar app framework version 2", but it show QRadar version need to greater than v7.3.3 FP6+.

    Is it any place can download new version Community Edition?

    thanks.



    ------------------------------
    Bruce T Wang
    ------------------------------



  • 4.  RE: IBM QRadar Community Edition How to patch

    Posted Thu September 02, 2021 05:08 AM
    Bruce,
    as Jonathan outlined already. You have to wait for the new version of CE. CE doesnt run the patch updater needed for FPs.
    If you need FP6+ you are better off with the full version which needs a bit more horsepower. This will kick off a time bombed license which should give you a couple of weeks of free usage. QRadar partners can buy a 1000EPS license for about 1000$
    If that exceeds you budget you need to reinstall after 6 weeks.
    Here is my lab version info. Its running the latest DAUs and WAUs as it sits on my INUC/ESX box and runs 24/7h.
    7.3.3 (Build 20191031163225)
    Tuning template is Enterprise
    Installed Options:
    Offenses
    Network Activity
    Installed Plug-Ins:
    Platform Configuration 
    QRadar Assistant 1.1.5
    QRadar Use Case Manager 3.1.0
    Internal build version: 2019.14.0.20191031163225.
    Installed on Mon Dec 28 16:54:16 2020
    OS is CentOS Linux release 7.7.1908 (Core)
    Kernel is Linux localhost.localdomain 3.10.0-1062.4.1.el7.x86_64 #1 SMP Fri Oct 18 17:15:30 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

    as you can see you can manually install DSMs, content packages and apps like use case manager 3.1.0. Also rpm install commands and others like yum will work as long as the prerequisites are available.
    However you are locked in the app framework version 1 which also blocks installation of the latest apps. Sorry no better news.
    Hoping for something new in 2021/2022?


    ------------------------------
    [Karl] [Jaeger] [Business Partner]
    [QRadar Specialist]
    [pro4bizz]
    [Karlsruhe] [Germany]
    [4972190981722]
    ------------------------------



  • 5.  RE: IBM QRadar Community Edition How to patch

    Posted Thu September 02, 2021 05:36 AM
    Karl,
    Thank you so much for the speedy reply.
    It seems that I need to install full version Qradar not CE version.

    Because I runing one project for creating Qradar Application, and IBM X-Force Exchange no longer accepts new apps using App Framework version 1.
    The option I can choose is using QRadar app framework version 2 on my project.

    Thanks, again.

    ------------------------------
    Bruce T Wang
    ------------------------------



  • 6.  RE: IBM QRadar Community Edition How to patch

    Posted Mon September 13, 2021 10:18 AM
    HI, you can update CE to fixpack8, but you need to install patches one by one. why not FP9? there is an issue with dependencies.

    ------------------------------
    Busine Classe
    ------------------------------