IBM Security Guardium

Expand all | Collapse all

STAP module for Oracle Linux 7.9 UEK6 5.4.17-2102.202.5

  • 1.  STAP module for Oracle Linux 7.9 UEK6 5.4.17-2102.202.5

    Posted Wed August 04, 2021 08:35 AM
    Hi all

    I want to know what STAP Bundle can i install on this OS ?

    For information :

    1. Kernel Version : 5.4.17-2102.202.5

    2. OS Version : Oracle Linux 7.9

    3. Database Version : Oracle 19C



    ------------------------------
    Mohamed Amine Errouifi
    ------------------------------


  • 2.  RE: STAP module for Oracle Linux 7.9 UEK6 5.4.17-2102.202.5

    Posted Thu August 05, 2021 01:52 PM
    STAP is not specific to kernel version.

    KTAP needs to closely match your kernel version. In most cases, a KTAP is prebuilt and distributed with the product.

    If a suitable ktap is not found during the install, you have two options:
     - have the KTAP built locally on your system. (This may require you to install a few .rpm packages)
     - request a custom-built KTAP be supplied under your support contract.

    https://www.ibm.com/docs/en/guardium/11.3?topic=tap-linux-unix-requesting-k-module

    ------------------------------
    Paul Spencer
    ------------------------------



  • 3.  RE: STAP module for Oracle Linux 7.9 UEK6 5.4.17-2102.202.5

    Posted Wed August 11, 2021 06:40 PM
    Hi Mohamed,

    I suppose the exact version number is: 5.4.17-2102.202.5.el7uek.x86_64, please confirm. You also can get the latest supported kernel list of v11.3 from below:
    https://ak-delivery04-mul.dhe.ibm.com/sar/CMA/IMA/09ijn/14/Guardium_11.3_KTAP_List.zip

    If it is 5.4.17-2102.202.5.el7uek.x86_64, please use below ktap:
    https://ak-delivery04-mul.dhe.ibm.com/sar/CMA/IMA/09vn0/0/Guardium_KTAP_11.3_rhel-7-linux-x86-64_r110195_2021-07-27.zip

    Below is all fix pack for v11 on fixcentral:
    https://www.ibm.com/support/fixcentral/swg/selectFixes?parent=IBM%20Security&product=ibm/Information+Management/InfoSphere+Guardium&release=11.0&platform=All&function=all

    ------------------------------
    Jonathan LU
    Security Support Engineer
    IBM
    ------------------------------