Power

 View Only
  • 1.  DNF Error

    Posted Wed March 20, 2024 02:04 AM

    Hi Team,

    I have successfully installed DNF in my server but when i give dnf repolist i am getting following error.

    >dnf repolist
    Traceback (most recent call last):
      File "/opt/freeware/bin/dnf", line 57, in <module>
        from dnf.cli import main
      File "/opt/freeware/lib/python3.9/site-packages/dnf/__init__.py", line 32, in <module>
        import dnf.base
      File "/opt/freeware/lib/python3.9/site-packages/dnf/base.py", line 29, in <module>
        import libdnf.transaction
      File "/opt/freeware/lib/python3.9/site-packages/libdnf/__init__.py", line 3, in <module>
        from . import common_types
      File "/opt/freeware/lib/python3.9/site-packages/libdnf/common_types.py", line 13, in <module>
        from . import _common_types
    ImportError:    0509-022 Cannot load module /usr/opt/rpm/lib/libpopt.a(libpopt.so.0).
            0509-150   Dependent module /opt/freeware/lib/libintl.a(libintl.so.8) could not be loaded.
            0509-152   Member libintl.so.8 is not found in archive
            0509-022 Cannot load module /opt/freeware/lib/python3.9/site-packages/libdnf/_common_types.so.

    Can you please help in resolving the issue.


            0509-150   Dependent module /usr/opt/rpm/lib/libpopt.a(libpopt.so.0) could not be loaded.



    ------------------------------
    Subba Reddy Reddem
    ------------------------------


  • 2.  RE: DNF Error

    Posted Thu March 21, 2024 11:49 AM

    Hi

    What version of AIX? Did you download the package from the link https://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/ezinstall/ppc/ ?

    I always download the latest version, that's if AIX has it on the latest version as well. Try using the command /usr/bin/updtvpkg 

    Richard



    ------------------------------
    Richard Fernandes
    ------------------------------



  • 3.  RE: DNF Error

    Posted Fri March 22, 2024 08:27 AM

    Hi Richard,

    My AIX version is AIX 7.2 and i have downloaded the tar file from the link mentioned by you only.



    ------------------------------
    Subba Reddy Reddem
    ------------------------------



  • 4.  RE: DNF Error

    Posted Mon April 08, 2024 02:22 PM

    [/opt/freeware/bin]@axscgpar1965#lslpp -l |egrep 'ssh|ssl'

      GSKit8.gskssl32.ppc.rte  8.0.55.26  COMMITTED  IBM GSKit SSL Runtime With

      GSKit8.gskssl64.ppc.rte  8.0.55.26  COMMITTED  IBM GSKit SSL Runtime With

      openssh.base.client   8.1.102.2106  COMMITTED  Open Secure Shell Commands

      openssh.base.server   8.1.102.2106  COMMITTED  Open Secure Shell Server

      openssh.license       8.1.102.2106  COMMITTED  Open Secure Shell License

      openssh.man.en_US     8.1.102.2106  COMMITTED  Open Secure Shell

      openssl.base            1.1.2.2000  COMMITTED  Open Secure Socket Layer

      openssl.license         1.1.2.2000  COMMITTED  Open Secure Socket License

      openssl.man.en_US       1.1.2.2000  COMMITTED  Open Secure Socket Layer

      openssh.base.client   8.1.102.2106  COMMITTED  Open Secure Shell Commands

      openssh.base.server   8.1.102.2106  COMMITTED  Open Secure Shell Server

      openssl.base            1.1.2.2000  COMMITTED  Open Secure Socket Layer

     

    The above openssh & openssl version dnf install works properly.



    ------------------------------
    Santosh Mohite
    ------------------------------