AIX Open Source

  • 1.  mutt fails after upgrading from 7.2 TL03 SP5 to 7.2 TL04 SP03

    Posted Fri September 24, 2021 03:29 AM
    Hi -
    We upgraded the OS from 7.2 TL03 SP5 to 7.2 TL04 SP03 and mutt fails with the below error as a regular user, but works as root.

    # mutt -s test -F mms exmaple@example.com <test Error sending message, child exited 72 (System file missing.). Segmentation fault

    Anyone get this to work?

    ​Thanks!

    ------------------------------
    Shawn Raymond
    ------------------------------


  • 2.  RE: mutt fails after upgrading from 7.2 TL03 SP5 to 7.2 TL04 SP03

    Posted Fri September 24, 2021 07:34 AM
    Are you using AIX toolbox mutt. 
    Can you please share "rpm -qi mutt" output ?
    I tried on my test system and I do not see any issue. This could be some local config error.
    Have you tried with some other user with default .muttrc file ?

    ------------------------------
    SANKET RATHI
    ------------------------------



  • 3.  RE: mutt fails after upgrading from 7.2 TL03 SP5 to 7.2 TL04 SP03

    Posted Fri September 24, 2021 08:05 AM
    Hi -

    Yes we're using the latest from the AIX toolbox.  It works as root, but not any other user.  We're not using a .mailrc file.  Thanks!

    $ rpm -qi mutt
    Name : mutt
    Version : 1.4.2.1
    Release : 1
    Architecture: ppc
    Install Date: Tue Nov 1 08:46:19 EDT 2011
    Group : Networking/Mail
    Size : 3779541
    License : GPL
    Signature : (none)
    Source RPM : mutt-1.4.2.1-1.src.rpm
    Build Date : Mon Sep 27 17:54:43 EDT 2004
    Build Host : emperor.aixpclab.austin.ibm.com
    Relocations : (not relocatable)
    URL : http://www.mutt.org/
    Summary : A text mode mail user agent.
    Description :
    Mutt is a text mode mail user agent. Mutt supports color, threading, arbitrary
    key remapping, and a lot of customization.

    You should install mutt if you're new to mail programs and you haven't decided
    which one you're going to use.


    ------------------------------
    Shawn Raymond
    ------------------------------



  • 4.  RE: mutt fails after upgrading from 7.2 TL03 SP5 to 7.2 TL04 SP03

    Posted Mon September 27, 2021 02:07 AM
    Edited by SANKET RATHI Mon September 27, 2021 08:40 AM
    I would recommend to try to on another server with clean install and see if the error persist. 

    We are working on newer version of mutt for AIX toolbox and it should be available soon.
    The current mutt on AIX toolbox is very old and built long back. It will be difficult to debug that.
    Once the new mutt is available please update. 

    ------------------------------
    SANKET RATHI
    ------------------------------



  • 5.  RE: mutt fails after upgrading from 7.2 TL03 SP5 to 7.2 TL04 SP03

    Posted Tue October 19, 2021 01:48 AM
    We got it working again by rejected senmail package, updated smmsp group to have gid=14 from gid=15, which is a mismatch to what deposited for smmsp in /etc/passwd, re-applied sendmail patch, and updated /etc/mail/{sendmail,submit}.cf file to include our local relay host instead of empty value for DS.
    Wonder why those steps fixed mutt?

    ------------------------------
    Hoa Le
    ------------------------------