AIX Open Source

Expand all | Collapse all

I cant locate this rpm fileset: AIX-rpm >= 7.2.0.0 is needed by libgcc-6.3.0-1.ppc

  • 1.  I cant locate this rpm fileset: AIX-rpm >= 7.2.0.0 is needed by libgcc-6.3.0-1.ppc

    Posted Thu September 09, 2021 10:14 AM
    root@cor089a051.us.parker.corp-/tmp# rpm -ivh libgcc-6.3.0-1.aix7.2.ppc.rpm
    error: Failed dependencies:
    AIX-rpm >= 7.2.0.0 is needed by libgcc-6.3.0-1.ppc
    root@cor089a051.us.parker.corp-/tmp# oslevel -s
    7200-04-02-2028

    ------------------------------
    Jim Courtright
    ------------------------------


  • 2.  RE: I cant locate this rpm fileset: AIX-rpm >= 7.2.0.0 is needed by libgcc-6.3.0-1.ppc

    Posted Fri September 10, 2021 09:18 AM
    AIX-rpm is a virtual package: https://www.ibm.com/support/pages/understanding-aix-virtual-rpm-package-rpmrte

    ------------------------------
    Erich Wolz
    ------------------------------



  • 3.  RE: I cant locate this rpm fileset: AIX-rpm >= 7.2.0.0 is needed by libgcc-6.3.0-1.ppc

    Posted Fri September 10, 2021 10:22 AM
    Thanks Eric.
    Yes AIX-rpm is a virtual rpm package that is created by rpm when it get installed.
    It provides information about some system libraries those are needed for RPM packages to work.
    In your case the problem I see is probably you are using AIX 7.2 package on lower level of AIX (eg AIX 7.1). 
    Or somehow AIX-rpm package is not there. 
    If it is earlier one that is your system lower than AIX 7.2 then please install AIX release specific libgcc. Most of the AIX packages from AIX toolbox (ppc/noarch dir) are built on AIX 6.1 and works on other higher level of AIX but some packages (specifically gcc or which ever is in ppc-6.1/ppc-7.1/ppc-7.2 dir) are built for specific AIX releases. 
    If this is not the case then please check you have AIX-rpm in your system and it is not deleted accidentally check with following command
    # rpm -qa | grep AIX-rpm
    If it is not there then run "updtvpkg" command to regenerate it.  ​

    ------------------------------
    SANKET RATHI
    ------------------------------



  • 4.  RE: I cant locate this rpm fileset: AIX-rpm >= 7.2.0.0 is needed by libgcc-6.3.0-1.ppc

    Posted Fri September 10, 2021 12:13 PM

     

    Well, now I'm getting this:

     

    root@cor089a051.us.parker.corp-/opt/IBM/mqsi/ace-11.0.0.13# ./ace make registry global accept license

    Could not load program mqsiexplain:

    Symbol resolution failed for /opt/IBM/mqsi/ace-11.0.0.13/server/lib/libnode.83.a because:

            Symbol _ZTTNSt7__cxx1119basic_ostringstreamIcSt11char_traitsIcESaIcEEE (number 458) is not exported from dependent

              module /opt/freeware/lib/pthread/ppc64/libstdc++.a[libstdc++.so.6].

            Symbol _ZTVNSt7__cxx1119basic_ostringstreamIcSt11char_traitsIcESaIcEEE (number 459) is not exported from dependent

              module /opt/freeware/lib/pthread/ppc64/libstdc++.a[libstdc++.so.6].

            Symbol _ZTVNSt7__cxx1115basic_stringbufIcSt11char_traitsIcESaIcEEE (number 460) is not exported from dependent

              module /opt/freeware/lib/pthread/ppc64/libstdc++.a[libstdc++.so.6].

            Symbol _ZTVNSt7__cxx1119basic_istringstreamIcSt11char_traitsIcESaIcEEE (number 462) is not exported from dependent

              module /opt/freeware/lib/pthread/ppc64/libstdc++.a[libstdc++.so.6].

            Symbol _ZTVNSt7__cxx1118basic_stringstreamIcSt11char_traitsIcESaIcEEE (number 463) is not exported from dependent

              module /opt/freeware/lib/pthread/ppc64/libstdc++.a[libstdc++.so.6].

            Symbol _ZTTNSt7__cxx1119basic_istringstreamIcSt11char_traitsIcESaIcEEE (number 469) is not exported from dependent

              module /opt/freeware/lib/pthread/ppc64/libstdc++.a[libstdc++.so.6].

            Symbol _ZTTNSt7__cxx1118basic_stringstreamIcSt11char_traitsIcESaIcEEE (number 470) is not exported from dependent

              module /opt/freeware/lib/pthread/ppc64/libstdc++.a[libstdc++.so.6].

            Symbol _ZNSt7__cxx1115basic_stringbufIcSt11char_traitsIcESaIcEED1Ev (number 483) is not exported from dependent

              module /opt/freeware/lib/pthread/ppc64/libstdc++.a[libstdc++.so.6].

            Symbol _ZNSt7__cxx1118basic_stringstreamIcSt11char_traitsIcESaIcEED1Ev (number 486) is not exported from dependent

              module /opt/freeware/lib/pthread/ppc64/libstdc++.a[libstdc++.so.6].

            Symbol _GLOBAL__AIXI_libstdc___so (number 487) is not exported from dependent

              module /opt/freeware/lib/pthread/ppc64/libstdc++.a[libstdc++.so.6].

            Symbol _GLOBAL__AIXD_libstdc___so (number 488) is not exported from dependent

              module /opt/freeware/lib/pthread/ppc64/libstdc++.a[libstdc++.so.6].

     






  • 5.  RE: I cant locate this rpm fileset: AIX-rpm >= 7.2.0.0 is needed by libgcc-6.3.0-1.ppc

    Posted Mon September 13, 2021 02:24 PM
    Hi Jim,

    I guess this is the suggested version to use.
    What's the output of /opt/freeware/lib/pthread/ppc64/libstdc++.a and also the link it points to.
    Also the the output of "dump -X64 -tov /opt/freeware/lib/pthread/ppc64/libstdc++.a | grep _ZTTNSt7__cxx1119basic_ostringstreamIcSt11char_traitsIcESaIcEEE"

    ------------------------------
    SANGAMESH
    ------------------------------



  • 6.  RE: I cant locate this rpm fileset: AIX-rpm >= 7.2.0.0 is needed by libgcc-6.3.0-1.ppc

    Posted Mon September 27, 2021 01:28 PM
    Sang, I'm currently get this error (attached): 


    ------------------------------
    Jim Courtright
    ------------------------------

    Attachment(s)



  • 7.  RE: I cant locate this rpm fileset: AIX-rpm >= 7.2.0.0 is needed by libgcc-6.3.0-1.ppc

    Posted Tue September 28, 2021 03:36 AM
    Use "rpm -Uvh libgcc-6.3.0-1.aix7.2.ppc.rpm" to update libgcc since you already have libgcc 4.8.3 installed.
    Also I presume you have ibstdc++ 4.8.3 already installed. So suggest you to download libstdc++ 6.3.0 rpm as well and pass it in the same command to update both.
    rpm -Uvh libgcc-6.3.0-1.aix7.2.ppc.rpm libstdc++-6.3.0-1.aix7.2.ppc.rpm


    ------------------------------
    Ayappan P
    ------------------------------



  • 8.  RE: I cant locate this rpm fileset: AIX-rpm >= 7.2.0.0 is needed by libgcc-6.3.0-1.ppc

    Posted Tue September 28, 2021 08:02 AM
    Well, i get this:
    root@cor089a051.us.parker.corp-/mnt/SYSADMIN/AIX/ACE# rpm -Uvh libgcc6-6.3.0-1.aix7.2.ppc.rpm
    Preparing... ################################# [100%]
    package libgcc6-6.3.0-1.ppc is already installed
    root@cor089a051.us.parker.corp-/mnt/SYSADMIN/AIX/ACE# rpm -Uvh libstdcplusplus6-6.3.0-1.aix7.2.ppc.rpm
    Preparing... ################################# [100%]
    package libstdc++6-6.3.0-1.ppc is already installed
    root@cor089a051.us.parker.corp-/mnt/SYSADMIN/AIX/ACE#


    ------------------------------
    Jim Courtright
    ------------------------------



  • 9.  RE: I cant locate this rpm fileset: AIX-rpm >= 7.2.0.0 is needed by libgcc-6.3.0-1.ppc

    Posted Tue September 28, 2021 08:34 AM
    Try running the /usr/sbin/updtvpkg command.

    ------------------------------
    Paul Clayton
    ------------------------------



  • 10.  RE: I cant locate this rpm fileset: AIX-rpm >= 7.2.0.0 is needed by libgcc-6.3.0-1.ppc

    Posted Tue September 28, 2021 08:38 AM
    https://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/RPMS/ppc-7.2/gcc/
    Here you will find libgcc-6.3.0-1.aix7.2.ppc.rpm and libstdcplusplus-6.3.0-1.aix7.2.ppc.rpm. Download it and then invoke " rpm -Uvh libgcc-6.3.0-1.aix7.2.ppc.rpm libstdcplusplus-6.3.0-1.aix7.2.ppc.rpm"



    ------------------------------
    Ayappan P
    ------------------------------