AIX Open Source

  • 1.  Dependent module /opt/freeware/lib/libintl.a(libintl.so.8) could not be loaded.

    Posted Wed September 22, 2021 07:03 PM
    Hi All,

    We are upgrading our Connect Direct 3.8 to 4.3. While installing it in the one of the server we are getting the below error:
    The customization procedure allows you to create configuration
    files for:

    (1) Configure the Connect:Direct for UNIX Server.
    (2) Configure the Connect:Direct for UNIX Client.
    (3) Configure the Connect:Direct for UNIX Server and Client.
    (4) Configurations requiring root privilege.
    (5) EXIT.


    Enter your choice:[3] 3
    exec(): 0509-036 Cannot load program /usr/bin/envsubst because of the following errors:
    0509-150 Dependent module /opt/freeware/lib/libintl.a(libintl.so.8) could not be loaded.
    0509-152 Member libintl.so.8 is not found in archive

    ================================================================

    Configuring Connect:Direct for UNIX Server

    ================================================================

    Please enter name of Connect:Direct node you want to customize: sapmpq
    exec(): 0509-036 Cannot load program /usr/bin/envsubst because of the following errors:
    0509-150 Dependent module /opt/freeware/lib/libintl.a(libintl.so.8) could not be loaded.
    0509-152 Member libintl.so.8 is not found in archive

    We have already raised one case with IBM Support team, They have checked and suggested:
    There is no AIX Support team for AIX Toolbox for Linux Applications packages, AIX Toolbox support is provided only through the Open Source Forum.

    Although we have tried to update rpm

    While tried to 1) Update rpm.rte

    We can see the reference blog provide (Update rpm.rte to the latest version to resolve rpm errors and core dumps)

    Ibm remove preview
    Update rpm.rte to the latest version to resolve rpm errors and core dumps
    importantFont {font-family: Arial, Helvetica, sans-serif!important;font-size: 14px!important;letter-spacing: .5px!important;word-spacing: .5px!important;color: #A04858!important;font-weight: 800!important;text-decoration: none!important;font-style: oblique!important;font-variant: normal!important;text-transform: none!important;}table.grayTableMain { border: 1px solid #1C6EA4 !important; background-color: #EAEAEA!important; width: 90%!important; text-align: left!important; border-collapse: collapse!important;}table.grayTableMain td, table.grayTableMain th { border: 1px solid #1C6EA4 !important; padding: 2px 2px!important;}table.grayTableMain tbody td, table.grayTableMain tbody div, table.grayTableMain tbody td, table.grayTableMain tbody
    View this on Ibm >

    )their is a strict warranty on that :

    **IMPORTANT: If your oslevel is < 7100-05, versions greater than 4.13.0.11 are not recommended.

    And I can confirm that my server oslevel is < 7100-05

    root@sapmpq:>oslevel -r

    7100-04

    so, I am unable to update rpm.rte. and follow the rest of the step, 

    2) Download gettext to a local directory: https://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/RPMS/ppc/gettext/gettext-0.20.2-1.aix6.1.ppc.rpm

    3) Update the gettext package

    # rpm -Uvh gettext-0.20.2-1.aix6.1.ppc.rpm

    Please help us to resolve this dependency issue ASAP.


    Regards





    ------------------------------
    Virendra Singh
    ------------------------------



  • 2.  RE: Dependent module /opt/freeware/lib/libintl.a(libintl.so.8) could not be loaded.

    Posted Wed September 22, 2021 07:03 PM
    You should be able to update to 4.13.0.11
    https://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/INSTALLP/ppc/rpm.rte.4.13.0.11

    ------------------------------
    Jan Harris
    ------------------------------



  • 3.  RE: Dependent module /opt/freeware/lib/libintl.a(libintl.so.8) could not be loaded.

    Posted Wed September 22, 2021 09:16 PM

    Hi Team,

    We have installed 4.13.0.11.

    But in installing gettext-0.20.2-1 we are getting losts of depemdemcy issue.

    Please help guide us for the further steps.

    root@sapmpq:>rpm -Uvh gettext-0.20.2-1.aix6.1.ppc.rpm

    error: Failed dependencies:

        glib2 >= 2.56.1 is needed by gettext-0.20.2-1.ppc

        libgcc >= 8.3.0 is needed by gettext-0.20.2-1.ppc

        libgomp >= 8.3.0 is needed by gettext-0.20.2-1.ppc

        libgomp.a(libgomp.so.1) is needed by gettext-0.20.2-1.ppc

        libiconv >= 1.16 is needed by gettext-0.20.2-1.ppc

        libiconv.a(libiconv.so.2) is needed by gettext-0.20.2-1.ppc

        libncurses.a(libncurses.so.6) is needed by gettext-0.20.2-1.ppc

        libstdc++ >= 8.3.0 is needed by gettext-0.20.2-1.ppc

        libtextstyle = 0.20.2-1 is needed by gettext-0.20.2-1.ppc

        libtextstyle.a(libtextstyle.so.0) is needed by gettext-0.20.2-1.ppc

        libunistring >= 0.9.9-2 is needed by gettext-0.20.2-1.ppc

        libunistring.a(libunistring.so.2) is needed by gettext-0.20.2-1.ppc

        libxml2 >= 2.9.9 is needed by gettext-0.20.2-1.ppc

        ncurses >= 6.2 is needed by gettext-0.20.2-1.ppc

        gettext = 0.17-1 is needed by (installed) gettext-devel-0.17-1.ppc

    root@sapmpq:>

    Regards



    ------------------------------
    Virendra Singh
    ------------------------------



  • 4.  RE: Dependent module /opt/freeware/lib/libintl.a(libintl.so.8) could not be loaded.

    Posted Thu September 23, 2021 03:51 AM

    You need to try to use yum for installing AIX Toolbox packages as it automatically resolves dependencies.
    https://developer.ibm.com/articles/configure-yum-on-aix/



    ------------------------------
    Ayappan P
    ------------------------------



  • 5.  RE: Dependent module /opt/freeware/lib/libintl.a(libintl.so.8) could not be loaded.

    Posted Thu September 23, 2021 09:00 PM
    Hi Team,

    We are facing some issue in installing the YUM:

    In the blog it is given the

    Prerequisites



    ------------------------------
    Virendra Singh
    ------------------------------



  • 6.  RE: Dependent module /opt/freeware/lib/libintl.a(libintl.so.8) could not be loaded.

    Posted Fri September 24, 2021 03:20 AM

    The stuff under pre-requisites are for basic understanding of rpm ,yum & httpd. Look further down for the main steps.



    ------------------------------
    Ayappan P
    ------------------------------



  • 7.  RE: Dependent module /opt/freeware/lib/libintl.a(libintl.so.8) could not be loaded.

    Posted Sat September 25, 2021 01:25 AM
    Edited by Virendra Singh Sat September 25, 2021 01:25 AM
    While trying to install yum_bundle.rpm getting below dependency. 
    Is there any direct procedure from IBM to install yum or configure yum ?

    Installing yum on AIX

    1. install latest rpm.rte: https://ftp.software.ibm.com/aix/freeSoftware/aixtoolbox/INSTALLP/ppc/
    # installp -qacXYd rpm.rte all

    2. install all rpm packages contained in yum_bundle.tar
    https://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/ezinstall/ppc/
    # tar -xvf yum_bundle.tar
    # rpm -Uvh *

    Package name yum_bundle.tar

    root@sapmpq:>rpm -Uvh *
    error: Failed dependencies:
    gettext = 0.17-1 is needed by (installed) gettext-devel-0.17-1.ppc



    ------------------------------
    Virendra Singh
    ------------------------------



  • 8.  RE: Dependent module /opt/freeware/lib/libintl.a(libintl.so.8) could not be loaded.

    Posted Sat September 25, 2021 02:27 AM
    --> gettext = 0.17-1 is needed by (installed) gettext-devel-0.17-1.ppc
    This old gettext 0.17-1 version is not from AIX Toolbox.  I would try to uninstall gettext-devel-0.17-1.ppc first. 


    ------------------------------
    Jan Harris
    ------------------------------