AIX Open Source

Expand all | Collapse all

Issues with RRDTOOL and FREETYPE2 updates for LPAR2RRD

  • 1.  Issues with RRDTOOL and FREETYPE2 updates for LPAR2RRD

    Posted Tue September 21, 2021 03:14 PM
    We are running our LPAR2RRD server on an AIX instance and try to keep up with the latest package releases for the AIX Toolbox. While we have managed to get perl 1:5.30.3-2 to update and run, we have not had any luck with getting rrdtool beyond version 1.7.0.3 and freetype2 beyond version 2.8-1. I know there was a bug in rrdtool 1.7.0.4, but I have tried all combinations of releases including 1.7.0.8 and cannot get rrdtool to load properly. The new version of freetype2 errors out no matter what version of rrdtool is running.

    I was wondering if anyone else has run into this issue and/or has any insight into why these newer packages don't seem to work with LPAR2RRD.

    Thanks,

    Keith Barth

    ------------------------------
    Keith Barth
    ------------------------------


  • 2.  RE: Issues with RRDTOOL and FREETYPE2 updates for LPAR2RRD

    Posted Wed September 22, 2021 03:41 AM
    Please share the error you are facing.

    ------------------------------
    Ayappan P
    ------------------------------



  • 3.  RE: Issues with RRDTOOL and FREETYPE2 updates for LPAR2RRD

    Posted Thu September 23, 2021 11:00 AM
    Ayappan,

    Here is the error I see when rrdtool tries to load in the LPAR2RRD load script after upgrading to any rrdtool version beyone 1.7.0.3:

    Could not load program /opt/freeware/bin/rrdtool:
    Symbol resolution failed for /opt/freeware/lib/librrd.a[librrd.so.8] because:
    Symbol _GLOBAL__AIXI_libpng16_so (number 7) is not exported from dependent
    module /opt/freeware/lib/libpng.a[libpng16.so.16].
    Symbol _GLOBAL__AIXD_libpng16_so (number 8) is not exported from dependent
    module /opt/freeware/lib/libpng.a[libpng16.so.16].

    Keith Barth

    ------------------------------
    Keith Barth
    ------------------------------



  • 4.  RE: Issues with RRDTOOL and FREETYPE2 updates for LPAR2RRD

    Posted Thu September 23, 2021 11:10 AM
    Looks like the installed libpng rpm is old . Try updating to the recent version (ie., 1.6.27-3) from AIX Toolbox.

    ------------------------------
    Ayappan P
    ------------------------------



  • 5.  RE: Issues with RRDTOOL and FREETYPE2 updates for LPAR2RRD

    Posted Thu September 23, 2021 03:16 PM
    I am having some problems installing the update.

    root@entlrrdd01: /home/su248549 >yum upgrade libpng-1.6.27-3.aix6.1.ppc.rpm
    Setting up Upgrade Process
    Examining libpng-1.6.27-3.aix6.1.ppc.rpm: libpng-1.6.27-3.ppc
    libpng-1.6.27-3.aix6.1.ppc.rpm: does not update installed package.
    No Packages marked for Update

    root@entlrrdd01: /home/su248549 >yum install libpng-1.6.27-3.aix6.1.ppc.rpm
    Setting up Install Process
    Examining libpng-1.6.27-3.aix6.1.ppc.rpm: libpng-1.6.27-3.ppc
    libpng-1.6.27-3.aix6.1.ppc.rpm: does not update installed package.
    Error: Nothing to do

    I checked and the listing in YUM shows the following:

    root@entlrrdd01: /root >yum list |grep libpng
    libpng.ppc 2:1.6.9-1 installed
    libpng-devel.ppc 1.6.27-3 AIX_Toolbox

    I thought about uninstalling the old libpng package, but I would end up removing a fair number of packages to do so:

    root@entlrrdd01: /home/su248549 >yum erase libpng.ppc
    Setting up Remove Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package libpng.ppc 2:1.6.9-1 will be erased
    --> Processing Dependency: libpng.a(libpng.so.3) for package: rrdtool-1.7.0-3.ppc
    --> Processing Dependency: libpng.a(libpng16.so.16) for package: rrdtool-1.7.0-3.ppc
    --> Processing Dependency: libpng15.a(libpng15.so.15) for package: rrdtool-1.7.0-3.ppc
    --> Processing Dependency: libpng16.a(libpng16.so.16) for package: cairo-1.14.6-2waixX11.ppc
    --> Processing Dependency: libpng >= 1.6 for package: cairo-1.14.6-2waixX11.ppc
    --> Processing Dependency: libpng >= 1.2.44 for package: rrdtool-1.7.0-3.ppc
    --> Running transaction check
    ---> Package cairo.ppc 0:1.14.6-2waixX11 will be erased
    --> Processing Dependency: libcairo.a(libcairo.so.2) for package: pango-1.40.1-2waixX11.ppc
    --> Processing Dependency: cairo >= 1.12.10 for package: pango-1.40.1-2waixX11.ppc
    ---> Package rrdtool.ppc 0:1.7.0-3 will be erased
    --> Processing Dependency: rrdtool = 1.7.0-3 for package: rrdtool-perl-1.7.0-3.ppc
    --> Running transaction check
    ---> Package pango.ppc 0:1.40.1-2waixX11 will be erased
    ---> Package rrdtool-perl.ppc 0:1.7.0-3 will be erased
    --> Finished Dependency Resolution

    Dependencies Resolved

    ==============================================================================================================================
    Package Arch Version Repository Size
    ==============================================================================================================================
    Removing:
    libpng ppc 2:1.6.9-1 installed 3.2 M
    Removing for dependencies:
    cairo ppc 1.14.6-2waixX11 @AIX_Toolbox 19 M
    pango ppc 1.40.1-2waixX11 @AIX_Toolbox 5.5 M
    rrdtool ppc 1.7.0-3 @/rrdtool-1.7.0-3.aix6.1.ppc 9.4 M
    rrdtool-perl ppc 1.7.0-3 @/rrdtool-perl-1.7.0-3.aix6.1.ppc 112 k

    Transaction Summary
    ==============================================================================================================================
    Remove 5 Packages

    Installed size: 37 M
    Is this ok [y/N]: N
    Exiting on user Command

    Any thoughts on a better way to approach updating this single package?


    ------------------------------
    Keith Barth
    ------------------------------



  • 6.  RE: Issues with RRDTOOL and FREETYPE2 updates for LPAR2RRD

    Posted Fri September 24, 2021 03:15 AM

    I don't know from where you got this libpng 2:1.6.9-1 rpm. It has the epoch field as "2". Hence it has higher precedence than version number so it won't allow the user to upgrade. You need to download the Toolbox libpng manually and forcefully upgrade it.

    rpm -Uvh --force libpng-1.6.27-3.aix6.1.ppc.rpm



    ------------------------------
    Ayappan P
    ------------------------------



  • 7.  RE: Issues with RRDTOOL and FREETYPE2 updates for LPAR2RRD

    Posted Fri September 24, 2021 11:26 AM
    Ayappan,

    I had to a little work, but I upgraded the libpng to version 1.6.27-3. I then upgraded rrdtool to version 1.7.0.7. When I executed the LPAR2RRD load script, it generated multiple instances of the following errors:

    ERROR : ERROR: rrd->ds_def malloc at /var/lpar2rrd/lpar2rrd/bin/LoadDataModule.pm line 646. :
    ERROR : ERROR: rrd->ds_def malloc at /var/lpar2rrd/lpar2rrd/bin/LoadDataModule.pm line 2079. :

    Fri Sep 24 09:40:57 2021: ERROR: rrd->ds_def malloc at /var/lpar2rrd/lpar2rrd/bin/LoadDataModule.pm line 646. :
    Use of uninitialized value $RRDp::error_mode in string eq at /opt/freeware/lib/perl5/5.30/vendor_perl/RRDp.pm line 168.
    Fri Sep 24 09:40:57 2021: ERROR: rrd->ds_def malloc at /var/lpar2rrd/lpar2rrd/bin/LoadDataModule.pm line 646. :
    Use of uninitialized value $RRDp::error_mode in string eq at /opt/freeware/lib/perl5/5.30/vendor_perl/RRDp.pm line 168.

    In the user interface I got the following message:

    ERROR: rrd->ds_def malloc at /var/lpar2rrd/lpar2rrd/bin/detail-cgi.pl line 8242

    It looks like there is some problem with the application code in relation to the newer version of rrdtool.

    ------------------------------
    Keith Barth
    ------------------------------



  • 8.  RE: Issues with RRDTOOL and FREETYPE2 updates for LPAR2RRD

    Posted Mon September 27, 2021 10:54 AM
    I did some additional research and the malloc errors are indicative of 64bit rrdtool attempting to manage data that was stored by the 32bit rrdtool. Can you confirm that rrdtool 1.7.0.3 defaults to 32bit and that the newer versions default to 64bit? If that is the case, should I be able to force the newer versions of rrdtool to use 32bit by pointing the application to /opt/freeware/bin/rrdtool_32 in the newer versions?

    ------------------------------
    Keith Barth
    ------------------------------



  • 9.  RE: Issues with RRDTOOL and FREETYPE2 updates for LPAR2RRD

    Posted Tue September 28, 2021 03:29 AM
    From version 1.7.0-6 onwards, 64bit is made the default. 
    Yes, you can point the application to use /opt/freeware/bin/rrdtool_32

    ------------------------------
    Ayappan P
    ------------------------------



  • 10.  RE: Issues with RRDTOOL and FREETYPE2 updates for LPAR2RRD

    Posted Wed October 27, 2021 02:05 PM
    That corrected the issue. For LPAR2RRD to work with the latest Perl and AIX Toolbox packages both the PERL and RRDTOOL variables in the lpar2rrd.cfg file  must point to the respective 32bit libraries (/opt/freeware/bin/rrdtool_32 and /opt/freeware/bin/perl_32). If anyone is interested in the current open source package compatibility matrix for this product, I have compiled one.



    ------------------------------
    Keith Barth
    ------------------------------



  • 11.  RE: Issues with RRDTOOL and FREETYPE2 updates for LPAR2RRD

    Posted 25 days ago
    Hi,

    the point is that you have to use rrdtool 32bit binaries when you upgrade from older rrdtool version which supported only 32bit and rrdtool DB files was already created by 32bit one.

    If you start from scratch (no historical data you have) then 64bit rrdtool works fine for lpar2rrd naturally.

    ------------------------------
    Simon Vaclavek
    ------------------------------