AIX Open Source

Expand all | Collapse all

yum check reports missing requires of libpopt.so after SP 7200-05-03 applied

  • 1.  yum check reports missing requires of libpopt.so after SP 7200-05-03 applied

    Posted Mon October 04, 2021 02:29 PM
    We have been using yum to manage open source packages on AIX for the last six months ago. We recently upgraded several servers from 7200-05-02 to 7200-05-03. Before the upgrade, yum check ran clean, but afterwards, we get the following message:

    # yum check
    rpm-3.0.5-49.ppc has missing requires of libpopt.so
    Error: check all

    We did run updtvpkg after the service pack was installed. I have not noticed any problems from this, just would like to see this command run clean before we start upgrading the rest of our servers.

    ------------------------------
    Robert Wood
    ------------------------------


  • 2.  RE: yum check reports missing requires of libpopt.so after SP 7200-05-03 applied

    Posted Mon October 04, 2021 02:51 PM
    Hello Robert
    rpm-3.0.5-49.ppc is not a package from the AIX Toolbox. Do you still have this package installed?

    ------------------------------
    Jan Harris
    ------------------------------



  • 3.  RE: yum check reports missing requires of libpopt.so after SP 7200-05-03 applied

    Posted Tue October 05, 2021 10:48 AM
    Interesting...I guess I assumed it was something that got installed when the rpm.rte fileset got installed, but apparently not. I'm not sure where that came from.

    I just tried removing rpm-3.0.5-49.ppc, which broke rpm/yum, but I was able to fix it by doing the following:
    1. Reinstall rpm.rte with overwrite option
    2. Reinstall latest sqlite package with --replacepkgs option
    3. Reinstall latest bzip2 package with --replacepkgs option

    Now the yum check runs clean. Thanks for your help!

    ------------------------------
    Robert Wood
    ------------------------------