AIX Open Source

Expand all | Collapse all

Git dependency of rpm aix

  • 1.  Git dependency of rpm aix

    Posted Mon October 11, 2021 12:58 AM
    Hi,

    I am getting below dependency on installing git.Have tried downloading many packages.Is someone familiar with this who can give me the exact tar bundle:

    rpm -ivh git-2.31.1-1.aix6.1.ppc.rpm
    error: Failed dependencies:
    /opt/freeware/bin/perl is needed by git-2.31.1-1.ppc
    gettext >= 0.19.8.1 is needed by git-2.31.1-1.ppc
    git-core = 2.31.1-1 is needed by git-2.31.1-1.ppc
    git-core-doc = 2.31.1-1 is needed by git-2.31.1-1.ppc
    less >= 551 is needed by git-2.31.1-1.ppc
    libiconv >= 1.14 is needed by git-2.31.1-1.ppc
    libiconv.a(libiconv.so.2) is needed by git-2.31.1-1.ppc
    python3 >= 3.7.10 is needed by git-2.31.1-1.ppc
    rsync >= 3.2.3 is needed by git-2.31.1-1.ppc
    zlib >= 1.2.11 is needed by git-2.31.1-1.ppc

    ------------------------------
    Tathagata Chatterjee
    ------------------------------


  • 2.  RE: Git dependency of rpm aix

    Posted Tue October 12, 2021 05:26 AM

    There are no tar bundles.

    Like all RPM-based distributions, your options are to manually construct a package or install yum and let it do the work for you.

    Get the yum package from https://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/ezinstall/ppc/

    Note: there's also a dnf package, but only for AIX v7. 



    ------------------------------
    José Pina Coelho
    Kyndryl
    ------------------------------