AIX Open Source

  • 1.  Dependency errors

    Posted Tue September 28, 2021 08:36 AM

    Hi All,

    So here is my tail of whoa.
    I recently returned to a company and started to investigate YUM dependency errors on all our AIX servers.
    What I can glean, is that certain packages are very specific to AIX 7.2, and there are plenty of dependencies going back to AIX7.1 and AIX6.1.

    I have rolled back all the packages and left the system with expat,tcl and tk and a few other to get me going.

    I then rolled out the yum installation twice, and yet I come back to the same issue each time. 
    Please see below.
    This is the sum total of packages currently installed.

    expect-5.42.1-3.ppc
    curl-7.52.1-1.ppc
    gettext-0.19.7-1.ppc
    sqlite-3.15.2-1.ppc
    db-4.8.24-3.ppc
    tk-8.4.7-4.ppc
    python-2.7.10-1.ppc
    python-urlgrabber-3.10.1-1.noarch
    python-devel-2.7.10-1.ppc
    python-tools-2.7.10-1.ppc
    yum-3.4.3-5.noarch
    zlib-1.2.7-1.ppc
    libstdc++-6.3.0-2.ppc
    zip-3.0-2.ppc
    gzip-1.10-1.ppc
    unzip-6.0-3.ppc
    lpar2rrd-agent-6.15-2.ppc
    ca-certificates-2016.10.7-2.ppc
    readline-6.1-2.ppc
    glib2-2.14.6-2.ppc
    gdbm-1.8.3-5.ppc
    tcl-8.4.7-4.ppc
    python-pycurl-7.19.3-1.ppc
    pysqlite-1.1.7-2.ppc
    python-iniparse-0.4-1.noarch
    yum-metadata-parser-1.1.4-2.ppc
    AIX-rpm-7.2.4.1-31.ppc
    libgcc-6.3.0-2.ppc
    bzip2-1.0.6-3.ppc
    expat-2.1.1-1.ppc
    
    --> Finished Dependency Resolution
    Error: Package: libstdc++8-8.3.0-6.ppc (AIX_Toolbox_71)
               Requires: AIX-rpm < 7.2.0.0
               Installed: AIX-rpm-7.2.4.1-31.ppc (installed)
                   AIX-rpm = 7.2.4.1-31
    Error: Package: libgcc8-8.3.0-6.ppc (AIX_Toolbox_71)
               Requires: AIX-rpm < 7.2.0.0
               Installed: AIX-rpm-7.2.4.1-31.ppc (installed)
                   AIX-rpm = 7.2.4.1-31
    Error: Package: 1:libstdc++-8-1.ppc (AIX_Toolbox_61)
               Requires: AIX-rpm < 6.2.0.0
               Installed: AIX-rpm-7.2.4.1-31.ppc (installed)
                   AIX-rpm = 7.2.4.1-31
    Error: Package: 1:libgomp-8-1.ppc (AIX_Toolbox_61)
               Requires: AIX-rpm < 6.2.0.0
               Installed: AIX-rpm-7.2.4.1-31.ppc (installed)
                   AIX-rpm = 7.2.4.1-31
    Error: Package: libgomp8-8.3.0-6.ppc (AIX_Toolbox_71)
               Requires: AIX-rpm < 7.2.0.0
               Installed: AIX-rpm-7.2.4.1-31.ppc (installed)
                   AIX-rpm = 7.2.4.1-31
    Error: Package: 1:libgcc-8-1.ppc (AIX_Toolbox_61)
               Requires: AIX-rpm < 6.2.0.0
               Installed: AIX-rpm-7.2.4.1-31.ppc (installed)
                   AIX-rpm = 7.2.4.1-31
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
    


    ------------------------------
    Paul Clayton
    ------------------------------


  • 2.  RE: Dependency errors

    Posted Tue September 28, 2021 08:48 AM
    Looks like AIX 6.1 & 7.1 specific repos are enabled on a AIX 7.2 system which should not be the case.
    Please check the /opt/freeware/etc/yum/yum.conf file. Only the ppc ,noarch & ppc-7.2 repos should be enabled.

    ------------------------------
    Ayappan P
    ------------------------------



  • 3.  RE: Dependency errors

    Posted Tue September 28, 2021 10:12 AM
    Hi,

    Thanx for the suggestion. It did fix the issue. 
    Not sure how I missed that one.

    Regards

    ------------------------------
    Paul Clayton
    ------------------------------