AIX Open Source

  • 1.  issue with yum after update

    Posted Fri September 10, 2021 09:21 AM
    We have 2 LAPR on which running Oracle 19c in RAC with ASM.

    hostname : oracle181 (node1)
    hostname : oracle182 (node2)

    on node2 i tried to install yum with yum.sh from ibm portal ( attach image viber_image_2021-09-09_14-02-49-097.jpg) after this i execute command yum update ( attach image viber_image_2021-09-09_14-04-24-403.jpg ) .

    Now when i try to run yum receive error :

    [root@oracle182]:/# yum list
    There was a problem importing one of the Python modules
    required to run yum. The error leading to this problem was:

    0509-130 Symbol resolution failed for /opt/freeware/lib/libglib-2.0.a(libglib-2.0.so.0) because:
    0509-136 Symbol _GLOBAL__AIXI_libiconv_so (number 161) is not exported from
    dependent module /opt/freeware/lib/libiconv.a(libiconv.so.2).
    0509-136 Symbol _GLOBAL__AIXD_libiconv_so (number 162) is not exported from
    dependent module /opt/freeware/lib/libiconv.a(libiconv.so.2).
    0509-022 Cannot load module /opt/freeware/lib/python2.7/site-packages/_sqlitecache.so.
    0509-026 System error: Cannot run a file that does not have a valid format.
    0509-192 Examine .loader section symbols with the
    'dump -Tv' command.

    Please install a package which provides this module, or
    verify that the module is installed correctly.

    It's possible that the above module doesn't match the
    current version of Python, which is:
    2.7.10 (default, Jun 22 2016, 05:57:59) [C]

    If you cannot solve this problem yourself, please go to
    the yum faq at:
    http://yum.baseurl.org/wiki/Faq


    [root@oracle182]:/#


    how to resolve this issue ?

    ------------------------------
    Hristo Penchev
    ------------------------------


  • 2.  RE: issue with yum after update

    Posted Mon September 20, 2021 03:11 AM
    I don't think the libiconv rpm installed is from AIX Toolbox. 
    Please install the Toolbox libiconv rpm ( 1.16-1 version ) and try again.

    ------------------------------
    Ayappan P
    ------------------------------



  • 3.  RE: issue with yum after update

    Posted Fri October 08, 2021 09:09 AM
    some of the dependent modules not loading were gone away when you use:
    export LIBPATH=/usr/opt/rpm/lib/:/opt/freeware/lib:$LIBPATH 

    ------------------------------
    Yashpal Nagar
    ------------------------------