AIX Open Source

Expand all | Collapse all

Connected Samba with AD, but it keeps promoting username and password

  • 1.  Connected Samba with AD, but it keeps promoting username and password

    Posted Fri August 13, 2021 02:52 PM
      |   view attached
    Hello
    i Connected Samba with windows AD, everything looks fine, #wbinfo -u get me the users of AD which means it joined the domain, but when I want to access the shared folder it keeps promoting username and password.

    Also, no matter how I enter AD user account, or Linux 'root' account, it already said login error and cannot allow me to enter. What wrong with my configurations?
    Stand alone server works perfect! but I need samba with AD

    My configs:
    [global]
    workgroup: XXX
    realm = my.domain
    security = ads
    idmap config * : range = 16777216-33554431
    template homedir = /home/%D/%U
    template shell = /bin/bash
    winbind use default domain = true
    winbind offline logon = false
    map to guest = bad user

    [Public]
    comment  = Public
    valid users = "@XXX\DOMAIN USERS"
    force group = "domain users"
    path = /share/p_files
    public = yes
    writable = yes 
    read only = no

    Thank you

    ------------------------------
    Piratheep Sivanantham
    ------------------------------


  • 2.  RE: Connected Samba with AD, but it keeps promoting username and password

    IBM Select
    Posted Mon August 16, 2021 08:50 AM
    I am sure there are more than one way to format AD groups in the SMB.CONF file but this works for us
    @"DOMAIN+group_name"​

    ------------------------------
    Don Larson
    ------------------------------



  • 3.  RE: Connected Samba with AD, but it keeps promoting username and password

    Posted Tue August 24, 2021 01:45 AM
    would you be able to share your conf file?

    ------------------------------
    Piratheep Sivanantham
    ------------------------------