AIX Open Source

  • 1.  Problems with first time YUM installation

    Posted Tue September 21, 2021 12:52 AM
    Hello,

    I am trying to install YUM on AIX 7.2 TL4 SP3 for the first time on a system that has LPAR2RRD installed on it.  When trying to install glib2-2.14.6-2.aix5.2.ppc.rpm. I get the following errors:

    # /usr/bin/rpm -Uvh glib2-2.14.6-2.aix5.2.ppc.rpm
    error: Failed dependencies:
    libgio-2.0.a(libgio-2.0.so.0) is needed by (installed) librsvg2-2.34.2-1.ppc - librsvg2-2.34.2-1.ppc
    libgio-2.0.a(libgio-2.0.so.0) is needed by (installed) gtk2-2.20.1-2.ppc - gtk2-2.20.1-2.ppc
    glib2 >= 2.22.5 is needed by (installed) librsvg2-2.34.2-1.ppc - librsvg2-2.34.2-1.ppc
    glib2 >= 2.17.3 is needed by (installed) pango-1.24.5-1.ppc - pango-1.24.5-1.ppc
    glib2 >= 2.22.5 is needed by (installed) cairo-1.12.14-1.ppc - cairo-1.12.14-1.ppc
    glib2 >= 2.22.5 is needed by (installed) atk-1.32.0-1.ppc - atk-1.32.0-1.ppc
    glib2 >= 2.24.2-1 is needed by (installed) gtk2-2.20.1-2.ppc - gtk2-2.20.1-2.ppc
    glib2 >= 2.22.5 is needed by (installed) rrdtool-1.4.8-2.ppc - rrdtool-1.4.8-2.ppc

    All of the other packages install fine.  However, when I try to run yum (e.g. "yum repolist") I get the following error:

    # yum repolist
    There was a problem importing one of the Python modules
    required to run yum. The error leading to this problem was:

    0509-022 Cannot load module /opt/freeware/lib/libglib-2.0.a(libglib-2.0.so.0).
    0509-150 Dependent module /usr/lib/libiconv.a(libiconv.so.2) could not be loaded.
    0509-152 Member libiconv.so.2 is not found in archive
    0509-022 Cannot load module /opt/freeware/lib/python2.7/site-packages/_sqlitecache.so.
    0509-150 Dependent module /opt/freeware/lib/libglib-2.0.a(libglib-2.0.so.0) could not be loaded.

    Please install a package which provides this module, or
    verify that the module is installed correctly.

    It's possible that the above module doesn't match the
    current version of Python, which is:
    2.7.10 (default, Jun 22 2016, 05:57:59) [C]

    If you cannot solve this problem yourself, please go to
    the yum faq at:
    http://yum.baseurl.org/wiki/Faq

    What am I missing, and what do I need to do to correct?

    Cheers, Richard






    ------------------------------
    Richard Robak
    ------------------------------


  • 2.  RE: Problems with first time YUM installation

    Posted Tue September 21, 2021 02:55 AM
    What is the need to install a very old version of glib2 ? Looks like the system already has newer glib2 installed. All these packages work together , so going back to a very old version will break things. That is what is shown in the rpm error. 
    For the yum error, please check whether you have any LIBPATH exported. We don't recommend to set any LIBPATH. Also please update the python version (2.7.10 is very old) and then try yum. If still facing issues, share the "rpm -qa" output here.

    ------------------------------
    Ayappan P
    ------------------------------



  • 3.  RE: Problems with first time YUM installation

    Posted Tue September 21, 2021 01:48 PM
    Ayappan - Thank you for your rapid response!

    I do not have "LIBPATH" set, the command "set | grep LIB" returns nothing.

    I tried to update python to 2.7.18-3, but get the following list of failed dependencies:

    # rpm -Uvh python-2.7.18-3.aix6.1.ppc.rpm
    error: Failed dependencies:
    bzip2 >= 1.0.8 is needed by python-2.7.18-3.ppc
    db >= 5.3.28 is needed by python-2.7.18-3.ppc
    expat >= 2.2.9 is needed by python-2.7.18-3.ppc
    gdbm >= 1.18.1 is needed by python-2.7.18-3.ppc
    gettext >= 0.19.8.1 is needed by python-2.7.18-3.ppc
    libdb-5.3.so is needed by python-2.7.18-3.ppc
    libffi >= 3.2.1 is needed by python-2.7.18-3.ppc
    libgcc >= 8.3.0 is needed by python-2.7.18-3.ppc
    libgdbm.a(libgdbm.so.6) is needed by python-2.7.18-3.ppc
    libncurses.so is needed by python-2.7.18-3.ppc
    libpanel.so is needed by python-2.7.18-3.ppc
    libstdc++ >= 8.3.0 is needed by python-2.7.18-3.ppc
    ncurses >= 6.2 is needed by python-2.7.18-3.ppc
    readline >= 8.0 is needed by python-2.7.18-3.ppc
    sqlite >= 3.32.3 is needed by python-2.7.18-3.ppc
    python = 2.7.10 is needed by (installed) python-devel-2.7.10-1.ppc
    python = 2.7.10 is needed by (installed) python-tools-2.7.10-1.ppc

    # rpm -Uvh python-tools-2.7.18-3.aix6.1.ppc.rpm
    error: Failed dependencies:
    python = 2.7.18-3 is needed by python-tools-2.7.18-3.ppc

    # rpm -Uvh python-devel-2.7.18-3.aix6.1.ppc.rpm
    error: Failed dependencies:
    python = 2.7.18-3 is needed by python-devel-2.7.18-3.ppc
    python < 2.7.18-3 conflicts with python-devel-2.7.18-3.ppc

    Here is the list of my rpm packages:

    # rpm -qa
    coreutils-5.2.1-2.ppc
    tar-1.14-2.ppc
    jbigkit-libs-2.0-2.ppc
    xft-2.1.6-5.ppc
    libxml2-2.9.1-1.ppc
    perl-XML-NamespaceSupport-1.11-1.noarch
    libart_lgpl-2.3.21-1.ppc
    libthai-0.1.18-1.ppc
    vim-common-6.3-1.ppc
    libffi-3.0.13-1.ppc
    gdbm-1.11-1.ppc
    libiconv-1.14-2.ppc
    dejavu-sans-mono-fonts-2.34-1.noarch
    perl-XML-LibXML-2.0012-1.ppc
    openssl-doc-1.0.2p-1.ppc
    bash-doc-4.2-2.ppc
    expat-2.1.0-1.ppc
    vim-enhanced-6.3-1.ppc
    libtiff-4.0.3-1.ppc
    gtk2-2.8.3-9.ppc
    glib2-2.30.3-2.ppc
    pango-1.24.5-1.ppc
    perl-XML-SAX-0.99-1.noarch
    sudo-1.8.25p1-1.ppc
    xz-libs-5.0.5-1.ppc
    openssl-devel-1.0.2p-1.ppc
    libdatrie-0.2.4-1.ppc
    xcursor-1.1.7-2.ppc
    libdbi-0.8.4-1.ppc
    perl-XML-Parser-2.41-1.ppc
    rrdtool-1.4.8-2.ppc
    curl-7.52.1-1.ppc
    gettext-0.19.7-1.ppc
    sqlite-3.15.2-1.ppc
    python-devel-2.7.10-1.ppc
    python-pycurl-7.19.3-1.ppc
    python-urlgrabber-3.10.1-1.noarch
    yum-metadata-parser-1.1.4-2.ppc
    libgcc-4.8.5-1.ppc
    perl-Net_SSLeay.pm-1.55-3.ppc
    perl-5.8.8-2.ppc
    rrdtool-perl-1.4.8-2.ppc
    less-382-1.ppc
    libjpeg-9a-1.ppc
    pixman-0.28.2-1.ppc
    bash-4.2-3.ppc
    dejavu-lgc-sans-mono-fonts-2.34-1.noarch
    perl-XML-Simple-2.18-1.noarch
    openssl-1.0.2p-1.ppc
    apache-1.3.31-3ssl.ppc
    libcroco-0.6.5-1.ppc
    zlib-1.2.11-1.ppc
    lzo-2.06-1.ppc
    librsvg2-2.34.2-1.ppc
    perl-TimeDate-1.20-1.noarch
    libXrender-0.9.8-1.ppc
    apache-manual-1.3.31-3ssl.ppc
    openldap-2.4.44-0.1.ppc
    freetype2-2.5.2-1.ppc
    xrender-0.9.1-2.ppc
    fontconfig-2.10.2-1.ppc
    libxcb-1.7-1.ppc
    perl-URI-1.58-1.noarch
    cairo-1.12.14-1.ppc
    apache-devel-1.3.31-3ssl.ppc
    gawk-3.1.3-1.ppc
    vim-minimal-6.3-1.ppc
    jasper-1.900.1-2.ppc
    libpng-1.6.9-1.ppc
    atk-1.32.0-1.ppc
    gtk2-2.20.1-2.ppc
    perl-XML-SAX-Base-1.08-1.noarch
    unzip-6.0-3.ppc
    ca-certificates-2016.10.7-2.ppc
    db-4.8.24-3.ppc
    readline-6.1-2.ppc
    python-2.7.10-1.ppc
    python-iniparse-0.4-1.noarch
    python-tools-2.7.10-1.ppc
    pysqlite-1.1.7-2.ppc
    yum-3.4.3-8.noarch
    perl-Crypt-SSLeay-0.57-2.ppc
    perl-IO-Tty-1.07-1.ppc
    AIX-rpm-7.2.4.1-18.ppc

    What do you recommend I do to resolve my issue?

    Cheers, Richard

    ------------------------------
    Richard Robak
    ------------------------------



  • 4.  RE: Problems with first time YUM installation

    Posted Wed September 22, 2021 03:13 AM

    Looks like the system has lot of rpms at different level. Manually updating them will be a huge effort. 
    So I would suggest to fix yum first. You can try forcefully installing glib2-2.14.6-2.aix5.2.ppc.rpm and then check whether yum is working or not. 
    rpm -Uvh --force glib2-2.14.6-2.aix5.2.ppc.rpm 

    And also openssl rpm is installed which might create problem. If possible , you can remove it and have only openssl lpp fileset installed.



    ------------------------------
    Ayappan P
    ------------------------------