AIX Open Source

  • 1.  unixODBC and libodbcinst.so

    IBM Select
    Posted Mon October 11, 2021 12:58 AM

    Hi,

    It appears that the unixODBC package between version 2.3.5-1 and 2.3.9-1 no longer includes /opt/freeware/lib/libodbcinst.so. Was this a conscious decision, or a package build issue? We have some applications that use that shared object library, but it's no longer available after updating to the latest unixODBC version.

    # rpm -ql unixODBC-2.3.5-1.ppc | grep libodbcinst.so
    /opt/freeware/lib/libodbcinst.so
    /opt/freeware/lib/libodbcinst.so.2
    /opt/freeware/lib/libodbcinst.so.2.0.0
    /opt/freeware/lib64/libodbcinst.so
    /opt/freeware/lib64/libodbcinst.so.2
    /opt/freeware/lib64/libodbcinst.so.2.0.0
    /usr/lib/libodbcinst.so
    /usr/lib/libodbcinst.so.2
    /usr/lib/libodbcinst.so.2.0.0
    /usr/lib64/libodbcinst.so
    /usr/lib64/libodbcinst.so.2
    /usr/lib64/libodbcinst.so.2.0.0

    # rpm -ql unixODBC-2.3.9-1.ppc | grep libodbcinst.so
    #


    Is there another way to build/generate those files for the latest unixODBC package?

    Regards,
    Kristian



    ------------------------------
    Kristian Milos
    ------------------------------


  • 2.  RE: unixODBC and libodbcinst.so

    Posted Tue October 12, 2021 03:30 AM
    Yes, we decided to provide archives instead of .so files as such with the package as it will be easy to maintain backward compatibility if we move to major version in the future. So applications need to be rebuilt to link to the archive or as a workaround, you can extract the archive. We suggest the former.

    ------------------------------
    RESHMA KUMAR
    ------------------------------



  • 3.  RE: unixODBC and libodbcinst.so

    IBM Select
    Posted Tue October 12, 2021 05:52 PM
    Appreciate the response, Reshma.
    I'll inform our application support teams of the required changes.

    ------------------------------
    Kristian Milos
    ------------------------------