AIX Open Source

  • 1.  YUM Configuration on 6.1

    Posted Wed September 22, 2021 07:04 PM
    I am facing challenge in installing yum in my AIX 6.1

    While running the yum.sh script , its giving below output for dependencies.

    gdbm-1.8.3-5 will be installed ...
    gettext-0.19.7-1 will be installed ...
    glib2-2.14.6-2 will be installed ...
    pysqlite-1.1.7-2 will be installed ...
    python-2.7.10-1 will be installed ...
    python-devel-2.7.10-1 will be installed ...
    python-iniparse-0.4-1 will be installed ...
    python-pycurl-7.19.3-1 will be installed ...
    python-tools-2.7.10-1 will be installed ...
    python-urlgrabber-3.10.1-1 will be installed ...
    readline-6.1-2 will be installed ...
    sqlite-3.15.2-1 will be installed ...
    yum-3.4.3-8 will be installed ...
    yum-metadata-parser-1.1.4-2 will be installed ...
    Installing the packages...
    error: Failed dependencies:
    libcrypto.a(libcrypto.so) is needed by curl-7.52.1-1.ppc
    libssl.a(libssl.so) is needed by curl-7.52.1-1.ppc
    libcrypto.a(libcrypto.so) is needed by python-2.7.10-1.ppc
    libssl.a(libssl.so) is needed by python-2.7.10-1.ppc
    libcrypto.a(libcrypto.so) is needed by python-pycurl-7.19.3-1.ppc

    Looking for answer for resolving these dependencies.



    ------------------------------
    preshit garg
    ------------------------------


  • 2.  RE: YUM Configuration on 6.1

    Posted Wed September 22, 2021 07:08 PM
    Your issue may be resolved by running /usr/sbin/updtvpkg.

    See Resolving RPM libssl.a and libcrypto.a errors
    https://www.ibm.com/support/pages/node/6258275

    To get the latest OpenSSL 
    See  Downloading and Installing or Upgrading OpenSSL and OpenSSH
    https://www.ibm.com/support/pages/node/720655

    ------------------------------
    Jan Harris
    ------------------------------



  • 3.  RE: YUM Configuration on 6.1

    Posted Thu September 23, 2021 11:12 AM
    Hello, I am trying to setup yum on AIX 7.2 and after running yum.sh and installing the packages, i get below error when i run yum repos.

    # yum repos
    There was a problem importing one of the Python modules
    required to run yum. The error leading to this problem was:

    0509-022 Cannot load module /usr/lib/libglib-2.0.a(libglib-2.0.so.0).
    0509-150 Dependent module /usr/lib/libiconv.a(libiconv.so.2) could not be loaded.
    0509-152 Member libiconv.so.2 is not found in archive
    0509-022 Cannot load module /opt/freeware/lib/python2.7/site-packages/_sqlitecache.so.
    0509-150 Dependent module /usr/lib/libglib-2.0.a(libglib-2.0.so.0) could not be loaded.

    Please install a package which provides this module, or
    verify that the module is installed correctly.

    It's possible that the above module doesn't match the
    current version of Python, which is:
    2.7.10 (default, Jun 22 2016, 05:57:59) [C]

    If you cannot solve this problem yourself, please go to
    the yum faq at:
    http://yum.baseurl.org/wiki/Faq


    root@pln-nim:/tmp
    # rpm -qa | grep python
    python-pycurl-7.19.3-1.ppc
    python-tools-2.7.10-1.ppc
    python-2.7.10-1.ppc
    python-iniparse-0.4-1.noarch
    python-urlgrabber-3.10.1-1.noarch
    python-devel-2.7.10-1.ppc
    root@pln-nim:/tmp

    ------------------------------
    Ghouse Mohammed
    ------------------------------



  • 4.  RE: YUM Configuration on 6.1

    Posted Fri September 24, 2021 03:48 AM

    Looks like the rpms are at different levels. Please share the "rpm -qa" output. 

    You can try to install the glib2 that comes with yum_bundle forcefully. Once yum starts working , then you can upgrade the packages.

    rpm -Uvh --force glib2...rpm



    ------------------------------
    Ayappan P
    ------------------------------



  • 5.  RE: YUM Configuration on 6.1

    Posted Wed September 29, 2021 12:55 PM
    # yum repos
    There was a problem importing one of the Python modules
    required to run yum. The error leading to this problem was:

    0509-022 Cannot load module /usr/lib/libglib-2.0.a(libglib-2.0.so.0).
    0509-150 Dependent module /usr/lib/libiconv.a(libiconv.so.2) could not be loaded.
    0509-152 Member libiconv.so.2 is not found in archive
    0509-022 Cannot load module /opt/freeware/lib/python2.7/site-packages/_sqlitecache.so.
    0509-150 Dependent module /usr/lib/libglib-2.0.a(libglib-2.0.so.0) could not be loaded.

    Please install a package which provides this module, or
    verify that the module is installed correctly.

    It's possible that the above module doesn't match the
    current version of Python, which is:
    2.7.10 (default, Jun 22 2016, 05:57:59) [C]

    If you cannot solve this problem yourself, please go to
    the yum faq at:
    http://yum.baseurl.org/wiki/Faq




    # rpm -qa
    expect-5.42.1-3.ppc
    tk-8.4.7-3.ppc
    gdbm-1.11-1.ppc
    pstree-2.36-1.ppc
    libiconv-1.15-1.ppc
    gettext-0.19.7-1.ppc
    yum-metadata-parser-1.1.4-2.ppc
    curl-7.52.1-1.ppc
    zlib-1.2.8-1.ppc
    freetype2-2.5.2-1.ppc
    fontconfig-2.10.2-1.ppc
    glib2-2.30.3-2.ppc
    libjpeg-9a-1.ppc
    xz-libs-5.0.5-1.ppc
    libXrender-0.9.8-1.ppc
    libthai-0.1.18-1.ppc
    pixman-0.28.2-1.ppc
    libxml2-2.9.1-1.ppc
    libxcb-1.7-1.ppc
    libdbi-0.8.4-1.ppc
    dejavu-sans-mono-fonts-2.34-1.noarch
    libcroco-0.6.5-1.ppc
    cairo-1.12.14-1.ppc
    perl-Crypt-SSLeay-0.57-2.ppc
    perl-5.8.8-2.ppc
    perl-TimeDate-1.20-1.noarch
    perl-XML-Parser-2.41-1.ppc
    perl-XML-LibXML-2.0012-1.ppc
    perl-XML-SAX-Base-1.08-1.noarch
    rrdtool-1.4.8-2.ppc
    openldap-2.4.40-1.ppc
    expat-2.1.1-1.ppc
    lpar2rrd-agent-7.20-1.ppc
    pysqlite-1.1.7-2.ppc
    python-pycurl-7.19.3-1.ppc
    yum-3.4.3-8.noarch
    python-tools-2.7.10-1.ppc
    tcl-8.4.7-3.ppc
    vnc-3.3.3r2-6.ppc
    readline-6.3-5.ppc
    bash-4.2-11.ppc
    info-5.2-1.ppc
    popt-1.16-1.ppc
    sqlite-3.15.2-1.ppc
    db-4.8.24-3.ppc
    ca-certificates-2016.10.7-2.ppc
    libpng-1.6.9-1.ppc
    libgcc-4.8.5-1.ppc
    libffi-3.0.13-1.ppc
    atk-1.32.0-1.ppc
    jbigkit-libs-2.0-2.ppc
    libtiff-4.0.3-1.ppc
    libdatrie-0.2.4-1.ppc
    jasper-1.900.1-2.ppc
    libart_lgpl-2.3.21-1.ppc
    librsvg2-2.34.2-1.ppc
    lzo-2.06-1.ppc
    dejavu-lgc-sans-mono-fonts-2.34-1.noarch
    openssl-1.0.1g-1.ppc
    pango-1.24.5-1.ppc
    gtk2-2.20.1-2.ppc
    perl-Net_SSLeay.pm-1.55-3.ppc
    perl-IO-Tty-1.07-1.ppc
    perl-URI-1.58-1.noarch
    perl-XML-Simple-2.18-1.noarch
    perl-XML-SAX-0.99-1.noarch
    perl-XML-NamespaceSupport-1.11-1.noarch
    rrdtool-perl-1.4.8-2.ppc
    lua-5.1.5-1.ppc
    pcre-8.33-1.ppc
    httpd-2.4.18-1.ppc
    python-2.7.10-1.ppc
    python-iniparse-0.4-1.noarch
    python-urlgrabber-3.10.1-1.noarch
    python-devel-2.7.10-1.ppc
    AIX-rpm-7.2.5.1-13.ppc

    ------------------------------
    Ghouse Mohammed
    ------------------------------



  • 6.  RE: YUM Configuration on 6.1

    Posted Thu September 30, 2021 04:30 AM
    https://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/RPMS/ppc/glib2/
    Get glib2-2.14.6-2 rpm from this location and forcefully install using " rpm -Uvh --force glib2-2.14.6-2...rpm "

    ------------------------------
    Ayappan P
    ------------------------------



  • 7.  RE: YUM Configuration on 6.1

    Posted Tue October 05, 2021 12:29 PM
    I tried to forcesfully install the below glib2 package version but get this below error.

    # rpm -Uvh --force glib2-2.14.6-2.aix5.2.ppc.rpm
    error: Failed dependencies:
    libgio-2.0.a(libgio-2.0.so.0) is needed by (installed) librsvg2-2.34.2-1.ppc
    libgio-2.0.a(libgio-2.0.so.0) is needed by (installed) gtk2-2.20.1-2.ppc
    glib2 >= 2.22.5 is needed by (installed) atk-1.32.0-1.ppc
    glib2 >= 2.22.5 is needed by (installed) librsvg2-2.34.2-1.ppc
    glib2 >= 2.17.3 is needed by (installed) pango-1.24.5-1.ppc
    glib2 >= 2.22.5 is needed by (installed) cairo-1.12.14-1.ppc
    glib2 >= 2.24.2-1 is needed by (installed) gtk2-2.20.1-2.ppc
    glib2 >= 2.22.5 is needed by (installed) rrdtool-1.4.8-2.ppc

    ------------------------------
    Ghouse Mohammed
    ------------------------------