Maximo EAM

 View Only

Wpmaterial requestnum is different from invreserve requestnum after created a workorder from a pm

  • 1.  Wpmaterial requestnum is different from invreserve requestnum after created a workorder from a pm

    Posted Tue February 22, 2022 04:47 PM
    Hi,

    When we create a workorder from a PM (generate workorder) which is associated to a jpnum containing itemnums, we can see the items showing in the newly created workorder. We also see that the wpmaterial.requestnum = invreserve.requestnum for the created workorder which is normal.

    Howerever, in some cases, the wpmaterial.requestnum has 1 digit difference with invreserve.requestnum. For example, for the same wonum, we got 156523 value for invreserve.requestnum and 15652for wpmaterial.requestnum.

    I don't know the exact cause for this but most of the cases we have are on workorders created from the PMWoGenCronTask chrontask. The created workorder status history shows ATTAPPRO (internal = WAPPR)  followed by PRET (internal = APPR) after the workorder is created from the pm.

    Is it normal to get wpmaterial.requestnum 1 digit higher than invreserve.requestnum ? It is like if a new record (new id) is added in wpmaterial table explaining the 1 digit difference.

    I found something related in APAR IZ74630 documentation but the issue was reported on 7.1.1.5 version and I'm using 7.6.1.1 version so I guess it was corrected.

    Any idea what could be the cause of this issue ?

    Thank you !

    ------------------------------
    Sylvain Bourgeois
    ------------------------------