Engineering System Design

 View Only
  • 1.  Importing profile that references a newer UML version, error

    Posted Thu March 25, 2021 09:29 AM
    Hi folks, new to the discussion group, looking forward to the exchange of ideas, problems and solutions.  I'm with Stellantis (formerly FCA Fiat-Chrysler, recently merged with PSA) in the vehicle integration/system safety area.

    In January OMG published the first version of their risk analysis profiles (RAAML) for use in MBSE tools (http://www.omg.org/spec/RAAML.  These profiles allow the user to construct DFMEA, FTA, STPA and ISO 26262 risk analysis elements in the MBSE space.

    I tried to import these profiles into Rhapsody v8.4 and ran into this message "Cannot determine UML version".  These RAAML profiles point to xmlns:uml="http://www.omg.org/spec/UML/20161101".  When I change this reference and point to xmlns:uml="http://www.omg.org/spec/UML/20110701", for instance, the profiles import but I have been advised that they will not work properly unless the original reference is used.

    So the question is whether there is a solution to this problem?  The developers of these profiles are all in the Cameo/MagicDraw environment and the profiles import and work fine for them, so I'm not finding an answer there.  Would appreciate any help/insights you might have, Thanks, Jerry



    ------------------------------
    Jerry Hendler
    ------------------------------


  • 2.  RE: Importing profile that references a newer UML version, error

    Posted Thu May 06, 2021 09:32 AM
    Answering my own post - IBM has confirmed that their importer function does not currently support UML v2.5.1 per that profile reference xmlns:uml="http://www.omg.org/spec/UML/20161101".  They expect to implement a fix in Rhapsody v9.0.3 to be deployed in Q2 or Q3 2021.

    ------------------------------
    Jerry Hendler
    ------------------------------



  • 3.  RE: Importing profile that references a newer UML version, error

    Posted Thu May 06, 2021 10:54 AM
    In the short term, just modify the xmlns:uml URL to 20131001


    XMI import



    ------------------------------
    steve rooks
    ------------------------------



  • 4.  RE: Importing profile that references a newer UML version, error

    Posted Thu May 06, 2021 10:54 AM
    Whilst waiting for the fix, if you change
    xmlns:uml="http://www.omg.org/spec/UML/20161101"
    To
    xmlns:uml="http://www.omg.org/spec/UML/20131001"

    The files will import

    ------------------------------
    steve rooks
    ------------------------------



  • 5.  RE: Importing profile that references a newer UML version, error

    Posted Thu May 06, 2021 11:06 AM
    Hi Steve, understood, in fact I tried that from the beginning and it does allow the import.  However, I am advised by my OMG contact who developed these specific risk analysis profiles that they require UML v2.5.1 to work correctly.  So while they will import they will not function as intended.  I can wait for the fix in Rhapsody v9.0.3 or you're welcome to send me a patch to try out once it's developed,  Thanks, Jerry

    ------------------------------
    Jerry Hendler
    ------------------------------



  • 6.  RE: Importing profile that references a newer UML version, error

    Posted Fri May 07, 2021 03:38 AM
    Thanks for sharing!

    ------------------------------
    Markus Nordstrand
    ------------------------------



  • 7.  RE: Importing profile that references a newer UML version, error

    Posted Wed May 26, 2021 03:04 AM
    Edited by Markus Nordstrand 18 days ago
    Hi Jerry,

    When I import the FMEA Library (ad-20-07-12.xmi) I get this error:
    The element type "type" must be terminated bu the matching end-tag "</type>".[line 111, column 7]:

    However, when I import the other libraries I do not get this error and they do not contain any "/type" anywhere.

    I am clueless about XMI and XML so I don't really know what to look for. Have you seen this problem and if so how did you solve it?

    /Markus Nordstrand

    EDIT: Andy lapping has released some learning of how to work with RAAML in Rhapsody here.

    ------------------------------
    Markus Nordstrand
    ------------------------------