Maximo Anywhere

  • 1.  CommLogId is null

    Posted Thu September 16, 2021 12:04 PM
    Hello Everyone,
    I am making a fairly simple change in WorkExecution to allow a commlog to be added.
    The issue i am having is that when the record is created a commlogid value is not being populated.
    This field is set to default to the autokey value but it never happens so an error is thrown.
    If i default the field to a value then the commlog record is created.
    I have done similar work with other objects(planned materials for example) and never ran into the key not being set.
    any thoughts on what the issue might be?
    i have tried changing some of the advanced settings on the objectstructure(wodetail\commlog). even tried creating an autoscript to populate the commlogid but the oslc structure complains since if commlogid is null.


    doug carrington

  • 2.  RE: CommLogId is null

    Posted Thu September 16, 2021 03:47 PM
    Hi Doug,

    It sounds like you need to configure the object structure to restrict the commlogid attribute so that Maximo uses the AUTOKEY to load the data:

    The process is pretty straightforward:

    1. Open the Object Structures application and bring up your object structure.
    2. Pick Inbound Setting Restrictions from the Select Action / More Actions menu.
    3. Click on the COMMLOG object in the objects list.
    4. Select the Override? checkbox for the COMMLOGID attribute.
    5. Select the Restricted? checkbox for the COMMLOGID attribute.  (You may need to select different objects on the screen to get Maximo to pick up your 'Override?' change so that it makes this checkbox editable.)
    6. Hit OK.

    The internal sequence columns are automatically restricted but that would only apply to the COMMLOGUID column so you need to manually restrict the commlogid column as well.

    Adam Davis
    Maximo Consultant
    Asset Partners
    Chicago IL

  • 3.  RE: CommLogId is null

    Posted Fri September 17, 2021 02:12 PM
    I have used that process many times while loading data.
    I went ahead and made the change and then restarted maximo but am still getting the same error

    doug carrington

  • 4.  RE: CommLogId is null

    Posted Sun September 19, 2021 04:08 AM
    It will good to check few of things here:
    1. From your post , I gather that commlog is a child table so can you share the relationship used for it. If the relationship query is not proper then you might be facing this issue. Check Maximo logs as well.
    2. Enable app debugging and extract the json request created your work execution app. This will help you understand the post request sent from the app and also resolve the issue. 
    3. I will also check if the rdf puller was run properly and resources were properly created in your app.xml.

    Biplab Choudhury
    Maximo Consultant
    Tata Consultancy Services

  • 5.  RE: CommLogId is null

    Posted Tue September 28, 2021 04:56 PM
    Sorry for delay in responding to this.  Just saw the thread:  Have you used this as a guide for how to Add the Comm log to Maximo Anywhere? Start with that and see if the procedures match with yours. Please let us know if that helps or not.

    Bradley K. Downing , MBA
    Solutions Engineer
    Bakersfield CA

  • 6.  RE: CommLogId is null

    Posted Tue September 28, 2021 05:07 PM
    commlog was already setup per that document before I got involved so they could view the logs. i added logic to add/edit commlog and send out the email notifications.
    I have it working but it was a combination of things. there were some advances settings/overrides on the object structure causing the autokey not to work. once I corrected that the save in anywhere still failed needing a value in commlogid so I set a default value which gets pass the error and the autokey is now workinging.

    doug carrington

  • 7.  RE: CommLogId is null

    Posted Tue September 28, 2021 05:12 PM
    I also added a commtemplate to the screen so the user could select one and the commlog would populate. It is a odd object in that the sendto is nonpersistent and calculated and the message doesn't like to display correctly due to rich text regardless of the cssClass. nothing is ever easy...

    doug carrington