EGL Development User Group

Expand all | Collapse all

egit integration with RBD 9.1

  • 1.  egit integration with RBD 9.1

    Posted Mon October 28, 2019 02:53 PM

    Hi ,

    Have anyone got successful integration with the eGit plugin in Rational Business Developer(RBD) software.. I am using RBD version 9.1, I have tried integrating the eGit using site  https://download.eclipse.org/egit/updates but it does not work.. Always fails with an error saying below error..

    Cannot complete the install because one or more required items could not be found.
      Software being installed: Git integration for Eclipse 5.5.1.201910021850-r (org.eclipse.egit.feature.group 5.5.1.201910021850-r)
      Missing requirement: Git integration for Eclipse 5.5.1.201910021850-r (org.eclipse.egit.feature.group 5.5.1.201910021850-r) requires 'org.eclipse.core.runtime [3.12.0,4.0.0)' but it could not be found

     

    Have anyone got this issue and resolved it ?

     

    Thanks in Advance

    Jeeva_S35


  • 2.  Re: egit integration with RBD 9.1

    Posted Tue October 29, 2019 02:17 AM

    Hi,

    The version from eGit update site is not compatible with RBD 9.1 which is based on eclipse 3.8

    Please refer to the eGit FAQ page about how to install it in older release of eclipse: https://wiki.eclipse.org/EGit/FAQ#Where_can_I_find_older_releases_of_EGit.3F

    According to the page, the eGit version 2.0.0.201206130900-r is targeted for eclipse 3.8.

    Thanks.

    jiyonghuang


  • 3.  Re: egit integration with RBD 9.1

    Posted Tue October 29, 2019 03:29 AM

    Hi This worked, I was able to add the egit plugin now successfully.. thank you..

    Jeeva_S35