Informix

 View Only
Expand all | Collapse all

PSORT_DBTEMP not working after upgrade to 14.10

  • 1.  PSORT_DBTEMP not working after upgrade to 14.10

    Posted Wed May 25, 2022 12:20 PM
    For some long time we were using script on Informix 11.7:
    #!/bin/ksh
    onmode -wm MAX_PDQPRIORITY=20
    export PSORT_DBTEMP=/SORT
    export PSORT_NPROCS=4
    dbaccess -e DB <<END
    execute function sort ();
    END
    onmode -wm MAX_PDQPRIORITY=1

    After upgrade to 14.10FC7 sorting to filesystem is not working, filesystem /SORT is always empty, 
    server is allocating more and more memory ... and we are getting ERROR: -208    :-((

    Thank you for any comments.

    Regards,

    Ivan Bednar

    ------------------------------
    Ivan Bednar
    ------------------------------


  • 2.  RE: PSORT_DBTEMP not working after upgrade to 14.10

    Posted Wed May 25, 2022 01:29 PM


    Hi,

    What are the DS_ and SHM_ onconfig parameters set to on each instance?
    Try with SET EXPLAIN ON, is the plan different between the instances?

    Are any environment variables different between the instance? (onstat -g env)?
    What does onstat -g ses for the session give whilst the sort is running?
    What does onstat -g mgm give whilst the query is running?

    Regards,

    David.



    ------------------------------
    David Williams
    ------------------------------



  • 3.  RE: PSORT_DBTEMP not working after upgrade to 14.10

    IBM Champion
    Posted Thu May 26, 2022 03:02 AM