Informix

Expand all | Collapse all

question about in-place upgrade

  • 1.  question about in-place upgrade

    Posted 21 days ago
    Hello

    i'm  suprised !!!!

    on this link it's said that we can upgrade in-place from 11.70 to 14.10
    BUT
    11.70 is compatible with AIX 6.1 and 7.1 and  not  with AIX 7.2
    14.10 is compatible with AIX7.2              but not  with AIX 6.1 and 7.1

    so can we really do an in-place upgrade from 11.70 to 14.10 ??

    https://informix.hcldoc.com/14.10/help/index.jsp?topic=%2Fcom.ibm.admin.doc%2Fids_admin_1399.htm

    Upgrading (In-place migration)Upgrading is a special case of migration that uses your existing hardware and operating system. You install a new or improved version of the product in a different location from your current version on the same machine. You can copy your configuration file and add new parameters. When you start the new Informix instance, the database data is automatically converted. For example, you can upgrade from Version 11.70 to Version 14.10.

    erating System Version Informix 14.10 Informix 12.10 Informix 11.70
    AIX 6.1 12.10.FC14
    Minimum TL 4, Service Pack 3
    11.70.FC9
    Minimum TL 4, Service Pack 3
    AIX 7.1 12.10.FC14 11.70.FC9
    AIX 7.2 14.10.FC5 12.10.FC14





    ------------------------------
    John Smith
    ------------------------------


  • 2.  RE: question about in-place upgrade

    Posted 21 days ago

    You can do an inplace from 11.7 to 14.10 but looks like you getting caught by the OS.

     

    Have you tried to install 14.10.FC < 5 on  AIX 7.1 ?

     

    Cheers

    Paul

     






  • 3.  RE: question about in-place upgrade

    Posted 21 days ago

    Informix and AIX.

    While 11.70 is not officially certified on AIX 7.2, it'll practically run fine there, especially later fixpacks (xC9W2). The lab runs some comparative benchmarks with 11.70 on AIX 7.2 and POWER9. 11.70.FC1 and few earlier fixpacks may not install from media, but if the INFORMIXDIR has been transferred (rsync,tar) it'll work just fine.

    The 14.10 is NOT supported on AIX 7.1 starting from xC1.

    Hope this helps.

    If anyone encounters issues with 11.70 on AIX 7.2 - please share details.



    ------------------------------
    Vladimir Kolobrodov
    ------------------------------



  • 4.  RE: question about in-place upgrade

    Posted 21 days ago
    Have you tried to install 14.10.FC < 5 on  AIX 7.1 ?
    ==> No, i don"t make any step without preparing, and it"s opposite of IBM compatibility matrix


    ------------------------------
    John Smith
    ------------------------------



  • 5.  RE: question about in-place upgrade

    Posted 21 days ago
    John:

    You can do the upgrade in-place from 11.70 to 14.10, but on AIX you have to jump through a few hoops:
    • Shutdown 11.70 under AIX 7.1/6.1
    • Upgrade the OS to 7.2
    • Start up 14.10 to perform the server upgrade
    You just cannot perform the upgrade of the engine safely under the earlier AIX versions or run the earlier engine safely under the newer OS version. And rolling back means reversing that:
    • Downgrade the Informix disk structures with onmode -b <version>
    • Downgrade the OS
    • Start up 11.70 

    Art

    ------------------------------
    Art S. Kagel, President and Principal Consultant
    ASK Database Management Corp.
    www.askdbmgt.com
    ------------------------------



  • 6.  RE: question about in-place upgrade

    Posted 21 days ago
    If there is OS upgrade Yes i agree:)

    ------------------------------
    John Smith
    ------------------------------