Informix

Expand all | Collapse all

Old dog trying to learn new tricks

  • 1.  Old dog trying to learn new tricks

    Posted Wed March 10, 2021 03:19 PM

    Ubuntu 20.04.2

    ids 14.10.FC5IE

     

    InformixHQ and IDS running on same server.

     

     

    I'm trying to implement InformixHQ for my work place.  I first installed Informix developers edition then installed the Innovator-C license. Then ran the jar file for HQ and tried opening HQ in browser using localhost:8080, and got logged in and changed admin password. I then got the agent jar file running.

     

    I got side track getting the systemd/system service files setup and working, so Informix, HQ and HQ agent will start automagically. I bit different then my HPUX days.

     

    After getting the systemd working I logged on to InformixHQ in the browser and added my localhost IDS to HQ.  It said it added with out error but is saying is offline.

     

    The agent status has green checkmark, the server status has "?" next to it. 

     

    I'm not sure what I did wrong or where to look for why HQ says the server offline. 

     

    I can get into dbaccess without problems, I even created a monitoring DB and a monitor user. 

     

    Just to make sure I didn't mess up the create of the monitor user, I removed the server and re-added using Informix for both admin and monitor users.  Same things. Server offline but agent green checkmark.

     

    When I added the server in InformixHQ I used the following information:

     

    Informix Server Name: oat3

    Informix Hostname: localhost

    Informix Port number: 9088

     

    My sqlhost looks like this:

     

    oat3 onsoctcp   localhost  9088

     

    so what stupid mistake did I make?  Or where do I find logs or more information on my InformixHQ saying the server is offline.

     

     

     

    John David Adamski

    Sr. Sysadmin/DBA

    Graceland University

    1 University Place, Lamoni, IA 50140

    adamski@graceland.edu

     



  • 2.  RE: Old dog trying to learn new tricks

    Posted Wed March 17, 2021 09:15 AM

    I'm still trying to get InformixHQ to see the server it running on.  I verified the firewall was allowing traffic and even added a rule to allow all traffic in to 9088.  That didn't seem to help.

     

    I tried a few other things and then stumbled across the lsof command and am wondering if this is showing the problem.  For port 9088 it says IPv6 shouldn't that say IPV4?  And if so how do I get it to IPv4?  Was there some config parameter I needed to set when installing Informix to do IPv4 not IPv6? Or some OS config?  This is my first time doing anything on ubuntu, maybe I should have picked another OS, like CentOS.

     

    root@oat3:~# lsof -i -P | grep 9088

    oninit     977        informix    5u  IPv6  31872      0t0  TCP ip6-localhost:9088 (LISTEN)

    oninit    1503            root    6u  IPv6  31872      0t0  TCP ip6-localhost:9088 (LISTEN)

     

    john

     






  • 3.  RE: Old dog trying to learn new tricks

    Posted Wed March 17, 2021 09:20 AM

    Nope, it should be fine.  There is some magic that binds it to both IPVersions. 

     

    However you can turn off IPV6 binding for the engine., just touch $INFORMIXDIR/etc/IFX_DISABLE_IPV6.

     

    If IPV6 is enable but not configured correctly you can have comms issues connecting to the engine

     

    Cheers

    Pauk

     






  • 4.  RE: Old dog trying to learn new tricks

    Posted Wed March 17, 2021 09:58 AM

    Thanks for the information

     

    Well drats I was hoping I found why can't connect to Informix on the server.  Back to the drawing board. 

     

    john

     






  • 5.  RE: Old dog trying to learn new tricks

    Posted Wed March 17, 2021 10:08 AM

    You can test misconfigured IPV6, telnet to the IPV4 IP and DB port, you will see a 408.  If you still can't connect via an app then turn disable the IPV6 (needs an engine bounce). Might clear it

     

    Cheers

    Paul

     






  • 6.  RE: Old dog trying to learn new tricks

    Posted Thu March 18, 2021 03:59 AM

    Also try inserting an asterisk in the sqlhosts file to listen on all interfaces:

    oat3  onsoctcp  *localhost  9088

    ------------------------------
    Doug Lawry
    Oninit Consulting
    ------------------------------



  • 7.  RE: Old dog trying to learn new tricks

    Posted Thu March 18, 2021 09:00 AM

    Well gave up on the ubuntu install and tried CentOS7 and got it all working.

     

    john

     






  • 8.  RE: Old dog trying to learn new tricks

    Posted Wed March 17, 2021 09:21 AM

    Nope, it should be fine.  There is some magic that binds it to both IPVersions. 

     

    However you can turn off IPV6 binding for the engine., just touch $INFORMIXDIR/etc/IFX_DISABLE_IPV6.

     

    If IPV6 is enable but not configured correctly you can have comms issues connecting to the engine

     

    Cheers

    Paul