Informix

Expand all | Collapse all

How to check autolocate settings ?

  • 1.  How to check autolocate settings ?

    Posted Sat June 12, 2021 01:20 AM
    Hello All,

    After setting AUTOLOCATE of onconfig to 3 as shown below, I set the location of the database using the administration API.
    The table seems to be successfully created in the specified dbspaces, but sysmaster:sysautolocate does not show the specified dbspace list.
    Is this a bug? Or is there another catalog table I can check?



    ** step

    $ onmode -wf AUTOLOCATE=3
    Value for AUTOLOCATE (3) was saved in config file.
    Value of AUTOLOCATE has been changed to 3.
    $ export DB_LOCALE=ko_kr.ksc
    $ export CLIENT_LOCALE=ko_kr.ksc
    $ dbaccess sysadmin -

    Database selected.

    > EXECUTE FUNCTION task("create database","demo","datadbs1","ko_kr.ksc");



    (expression) Database demo created

    1 row(s) retrieved.

    > EXECUTE FUNCTION task("autolocate database", "demo", "datadbs1,datadbs2");



    (expression) OK



    $ echo "select * from sysautolocate" | dbaccess sysmaster

    Database selected.




    dbsnum 0
    dbsname *
    pagesize 0
    flags 1

    1 row(s) retrieved.


    ------------------------------
    SangGyu Jeong
    Software Engineer
    Infrasoft
    Seoul Korea, Republic of
    ------------------------------


  • 2.  RE: How to check autolocate settings ?

    Posted Mon June 14, 2021 04:42 AM
    Hi,

    There is a 'sysautolocate' table in every database.

    select * from demo:sysautolocate;

    is probably what you want :)

    Ben.

    ------------------------------
    Benjamin Thompson
    ------------------------------



  • 3.  RE: How to check autolocate settings ?

    Posted Mon June 14, 2021 08:18 AM
    @Benjamin Thompson
    ​Oops... I was using it completely wrong. Thanks for the reply.

    ------------------------------
    SangGyu Jeong
    Software Engineer
    Infrasoft
    Seoul Korea, Republic of
    ------------------------------