Informix

nested-group-icon.png

DB2

Sporadically onstat fails with Cannot attach to shared memory. errno = 22

  • 1.  Sporadically onstat fails with Cannot attach to shared memory. errno = 22

    Posted Tue December 15, 2020 09:00 AM
    Hi,

    i've the problem that sometimes (random) onstat commands fails with following error:

    14:53:31  shmat: [22]: operating system error
    14:53:31  Client could not attach server shared memory segment, use IFX_XFER_SHMBASE.
    MapViewOfFileEx: w32ec=487 at nt_shm.c:735
    onstat: Cannot attach to shared memory. errno = 22​

    Errorlevel returned is 255.


    OS:
    Server 2019

    Informix:
    14.10FC5WE

    But the problem is accross all server and all informix versions since 14.10.

    I've tried it with different SHM settings, but the error apears everytime:

    #RESIDENT -1
    RESIDENT 0
    
    #SHMBASE 0x80000000L
    #SHMBASE 0x141460000L
    SHMBASE 0x150000000L
    
    #SHMVIRTSIZE 6291456
    SHMVIRTSIZE 1048576
    
    #SHMADD 3145728
    SHMADD 204800 #add in 200mb lots 
    
    EXTSHMADD 8192
    SHMTOTAL 33554432
    SHMVIRT_ALLOCSEG 0,3
    
    #SHMNOACCESS 0x70000000-0x7FFFFFFF​


    To reproduce the error you can use this cmd script:

    @echo off
    
    set INFORMIXDIR=xxxxx
    set INFORMIXSERVER=xxxx
    
    :START
    onstat.exe - >> onstat.txt 2>&1
    echo ErrorLevel: %errorlevel% >> onstat.txt
    
    if %errorlevel% neq 5 exit
    
    GOTO START

    Sometimes the onstat is working ~30 times, sometimes ~300 times.

    I can't see a system here.

    Thanks.



    ------------------------------
    Josef Albert
    ------------------------------