Db2 On Premise and Cloud

Expand all | Collapse all

connect to dev edition

  • 1.  connect to dev edition

    Posted Wed July 03, 2019 01:09 PM
    installed db2 11.5 on ubuntu : all ok
    databases ok
    trying a remote connection : returns sql3081 connect 111 : connection refused
    is it allowed with  "IBM DB2 Developer-C Edition" to connect from remote client
    I am trying to configure dsm and repository

    ------------------------------
    Thanks for all answers
    Best Regards,
    Guy Przytula
    ------------------------------


  • 2.  RE: connect to dev edition

    Posted Thu July 04, 2019 05:31 AM
    Hi Guy,

    did you set the DB2COMM properly ?

    What do you recieve if you start a telnet session from db2 client to the port on your db2 server ?

    ------------------------------
    Ferdinand Prahst
    ------------------------------



  • 3.  RE: connect to dev edition

    Posted Thu July 04, 2019 06:39 AM
    yes of course
    this was an existing installation of 11.1.4 and upgraded to 11.5
    dsm was working before - in the same machine - but if you configure repos, it will do external connection
    i also tried to catalog the db with node/db and same result

    ------------------------------
    Thanks for all answers
    Best Regards,
    Guy Przytula
    ------------------------------



  • 4.  RE: connect to dev edition

    Posted Fri July 05, 2019 09:39 AM
    If you issue a connect from somewhere remote to the DSM repository, do you see an error message in the db2 error log. That can help narrow down if you are connecting and running into a problem or if you aren't even getting near the database. Can you ping the DSM database server from your remote client either by hostname (i.e. devbox.com) or IP (ie 192.x.x.x)?

    The error you are reporting is usually caused by the DNS hostname not being mapped to an IP address on the connecting client (i.e. the client doesn't know devbox.com maps to 192.x.x.x) or the port is wrong/closed.

    What happens if you try to ping the sever from your client and is there a problem reported in the error log?

    ------------------------------
    Michael Krafick
    ------------------------------



  • 5.  RE: connect to dev edition

    Posted Mon July 08, 2019 08:32 AM
    after reboot of the vm - the problem was resolved - do not know why - settings have not been changed

    ------------------------------
    Guy Przytula
    ------------------------------



  • 6.  RE: connect to dev edition

    Posted Tue July 09, 2019 08:57 AM
    It may not have been the VM, it could be that a parameter wasn't in affect yet and the reboot helped. I'm glad you were able to get past it.

    ------------------------------
    Michael Krafick
    ------------------------------