Db2 (On Premises and Cloud)

Install fails with "Error applying transforms" message - fixed

  • 1.  Install fails with "Error applying transforms" message - fixed

    Posted 30 days ago

    NOTE:   The following is no longer a problem as of the 05/04/2016 WIndows 64-bit beta driver.  I was able to install and use it without any problems.

    I'm trying to install the DB2 V11.1 beta on Windows 7 Professional 64-bit system.   I'm logged on as an administrator, and I've run setup.exe with elevated authority.   I keep getting the same error:

    Error applying transforms. Verify that the specified transform paths are valid.

    The log file for the install was empty.   I found I could at least get something in the log file if I started setup.exe using the /t flag.  This is what I get now:

    === Verbose logging started: 5/3/2016  9:26:35  Build type: SHIP UNICODE 5.00.7601.00  Calling process: C:\windows\system32\MSIEXEC.EXE ===
    MSI (c) (BC:20) [09:26:35:251]: Font created.  Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg
    MSI (c) (BC:20) [09:26:35:251]: Font created.  Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg
    MSI (c) (BC:CC) [09:26:35:255]: Resetting cached policy values
    MSI (c) (BC:CC) [09:26:35:255]: Machine policy value 'Debug' is 0
    MSI (c) (BC:CC) [09:26:35:255]: ******* RunEngine:
               ******* Product: C:\devinst\db2_v111\ntx64\B16032~1\SERVER\image\db2\Windows\DB2 Server.msi
               ******* Action:
               ******* CommandLine: **********
    MSI (c) (BC:CC) [09:26:35:259]: Machine policy value 'TransformsSecure' is 0
    MSI (c) (BC:CC) [09:26:35:259]: User policy value 'TransformsAtSource' is 0
    MSI (c) (BC:CC) [09:26:35:260]: Note: 1: 2203 2: ESEinst0.mst 3: -2147287038
    MSI (c) (BC:CC) [09:26:35:260]: MainEngineThread is returning 1624
    === Verbose logging stopped: 5/3/2016  9:26:35 ===

    I used to have DB2 10.5 on my system, but I uninstalled that before trying to install the beta.   When I ran into this error, I even tried using db2unins /f to remove any remnants of DB2, but that didn't make any difference.

    Any idea what could be causing this error, and what I could do to get past it?

    (Note:  I don't know if this gives you build level information, but the beta unzipped to C:\devinst\db2_v111\ntx64\b1603231900\SERVER\image...)