Db2 On Premise and Cloud

 View Only
Expand all | Collapse all

DMC - 3.1.5.1 - Getting an exception HWCMON0004W: Your database is not supported. Only Db2 databases, version 10.5.4 and above are supported.

  • 1.  DMC - 3.1.5.1 - Getting an exception HWCMON0004W: Your database is not supported. Only Db2 databases, version 10.5.4 and above are supported.

    InnerCircle
    Posted Fri March 04, 2022 06:10 PM

    Our monitored database version is - v11.5.7.0 
    Repository database version is - DB2 v11.5.5.1

    While adding connection profile getting following exception, though the test connection was successful on add monitoring profile page.  

    "HWCMON0004W: Your database is not supported. Only Db2 databases, version 10.5.4 and above are supported."
    "HWCMON0008E: Monitoring metrics cannot be retrieved successfully because of an internal error. You can try again later. If the problem persists, contact the administrator. For more details, see the exception reported in the monitoring log file."



    ------------------------------
    Krishna Murakonda
    ------------------------------



  • 2.  RE: DMC - 3.1.5.1 - Getting an exception HWCMON0004W: Your database is not supported. Only Db2 databases, version 10.5.4 and above are supported.

    Posted Mon March 07, 2022 11:23 AM
    Hello Krishna,
    There are some situations where DMC does not recognize the database level on the monitored database:
    1.) The database is not updated with the latest db2level.  Please run the following command to confirm that:
    db2 "select versionnumber from sysibm.sysversions order by 1 desc"
    Make sure that the latest release matches your db2level.
    If it doesn't, you will need to run the Db2 db2updv115 command to update the internal Db2 APIs:
    https://www.ibm.com/docs/en/db2/11.5?topic=sc-db2updv115-update-database-version-115-fix-pack-command

    2.) The userid connecting to the monitored database does not have enough privileges to get the database level information.
    Please confirm if the user has the required privileges according to the DMC manual at:
    https://www.ibm.com/docs/en/db2-data-mgr-console/3.1.x?topic=console-min-db-privileges-required-db2

    3.) There was an issue with earlier releases of DMC where in certain conditions, DMC was not able to check the database level.
    My recommendation is to download and install DMC V3.1.7:
    https://www.ibm.com/support/pages/node/885789

    If the problem persists after my recommendation, please create a case so we can take a look at the DMC log files for further analysis.
    I hope that helps!


    ------------------------------
    Cintia Ogura
    ------------------------------



  • 3.  RE: DMC - 3.1.5.1 - Getting an exception HWCMON0004W: Your database is not supported. Only Db2 databases, version 10.5.4 and above are supported.

    Posted Fri April 01, 2022 02:43 AM
    Hello Krishna, could you please let me know the current status of this case? Thanks!​

    ------------------------------
    Tian Jiao Zhang
    ------------------------------