Informix

Informix

Connect with Db2, Informix, Netezza, open source, and other data experts to gain value from your data, share insights, and solve problems.

 View Only
  • 1.  IBM Informix Standalone Container v2.0.0 - Images not found in cp.icr.io/cp/

    Posted 06/03/26 09:57 AM

    Hello,

    I am trying to deploy IBM Informix Standalone Container v2.0.0 on Red Hat OpenShift using the CASE bundle from: https://github.com/IBM/cloud-pak/tree/master/repo/case/ibm-informix-standalone

    The operator deploys successfully, but pods fail with ErrImagePull for images like:

    • icr.io/cp/informix-hq
    • icr.io/cp/informix-cm
    • icr.io/cp/informix-eng

    Error: manifest unknown on both icr.io/cp/ and cp.icr.io/cp/

    I have a valid IBM Software Access entitlement key with "all" container software access.

    Could you please confirm:

    1. The exact image names and tags available in the registry?
    2. The correct registry URL for Informix Standalone Container v2.0.0?

    Thank you!



    ------------------------------
    Ivelina Vardeva
    ------------------------------


  • 2.  RE: IBM Informix Standalone Container v2.0.0 - Images not found in cp.icr.io/cp/

    Posted 06/17/26 11:57 AM

    Hello Ivelina,

    Can you do two things for me ?
    First, can you provide the image digests the pods are referencing when pulling the images?
    Second, if you delete a pod does it successfully pull the image ?

    Regards,


    Dan Weber



    ------------------------------
    Daniel Weber
    ------------------------------



  • 3.  RE: IBM Informix Standalone Container v2.0.0 - Images not found in cp.icr.io/cp/

    Posted 06/17/26 11:57 AM

    Hi,

    We are looking into this but need additional info. Please share the digest of one of the images from a pod in the image pull error state and what happens if you restart (delete) the pod ?

    Thanks!



    ------------------------------
    Karen Qualley
    ------------------------------



  • 4.  RE: IBM Informix Standalone Container v2.0.0 - Images not found in cp.icr.io/cp/

    Posted 06/24/26 10:35 AM

    The location of the images are as follows - 

    icr.io/cpopen/informix/informix-hq:2.0.0-0000-x86_64

    I'm looking into why the charts aren't using the case validated path for the deployment.



    ------------------------------
    Daniel Weber
    ------------------------------



  • 5.  RE: IBM Informix Standalone Container v2.0.0 - Images not found in cp.icr.io/cp/

    Posted 06/25/26 08:54 AM

    I believe I found where the invalid path is being interjected into the resource yaml files.  Investing a workaround using an image mirror configuration.



    ------------------------------
    Daniel Weber
    ------------------------------