SPSS Statistics

Expand all | Collapse all

Robust Regression and Essentials For R Plugin - need some help!

  • 1.  Robust Regression and Essentials For R Plugin - need some help!

    Posted Sun September 20, 2020 12:45 AM
    Dear SPSS community,

    I'm using SPSS Version 26. I wish to run a robust regression. I've downloaded the Robust Regression package from the Extensions Hub in SPSS 26.

    I've also installed the integration plug-in for R (the Extensions Requirements window from the Extensions Hub reports that "Your system meets the requirements to run the SPSSINC_ROBUST_REGR extension").

    However, when I run the robust regression I get no results. The Log in the Output file simply refers to the variables entered.

    I note from the HELP tab on the Robust Regression window, the requirements to run the package include the Integration Plug-in for R and the R MASS package. I'm not sure if I have the "R MASS package"? Could this be the problem?

    Any suggestions would be appreciated!

    Thank you

    Jonathan








    ------------------------------
    Jonathan FOX
    ------------------------------


  • 2.  RE: Robust Regression and Essentials For R Plugin - need some help!

    Posted Sun September 20, 2020 12:06 PM
    Are  you on a Mac?  The Mac OS used to include X11 support, which is required for the R connection, but it no longer does. :-(

    On Mac OS X if you use R, you must have a copy of XQuartz, the X11 window manager, installed. This is no longer a default install since Mac OS X 10.8. ... You can get it from https://xquartz.macosforge.org/landing/

    ------------------------------
    Jon Peck
    ------------------------------