Cognos Analytics

Expand all | Collapse all

Communication error code:503

  • 1.  Communication error code:503

    Posted Thu January 17, 2019 11:15 AM
    Edited by Cindy Berry Thu January 17, 2019 11:30 AM
    Hello,
    I am using Cloud trial 11.1 and for the past 3 days I've received a "Communication Error. A network error has occurred: Http code: 503" on visualizations which then don't render. This is on a dashboard created last week and on new visualizations in Explore, Dashboard & Storyboard I've been trying to create since Tuesday.

    I've tried replacing the data source, and get a different reason for the error on each visualization, but the Comm Error pop up is the same.

    Who can I contact to help me understand or address the issue? I sent a message to the 'contact us' link in the top right corner of this community and  haven't received a response.

    Links to version in use: https://tryca.ca.analytics.ibm.comComm error w/ failed visuals

    ------------------------------
    Kindest regards,
    Cindy Berry
    WH Payer Provider Design
    UX Designer
    ------------------------------


  • 2.  RE: Communication error code:503

    Posted Fri January 18, 2019 10:56 AM
    Hi,

    Yes,  I have the same problem. In the trial version Cognos Analytic on Cloud 11.1 R1 in each moment sends the below error: A network error has occurred.

    ------------------------------
    Jorge Daniel Anguiano Morales
    CEO
    TI SENCEI - Soluciones en la Nube - Capacitación e Implementación
    Querétaro QUE
    Mobile
    ------------------------------



  • 3.  RE: Communication error code:503

    Posted Sun January 20, 2019 11:14 PM
    Dear Team,

    While using the trail version of cognos analytics I am finding it very difficult to load visualizations already created. Multiple times the error remains the same as "Cannot retrieve data from dataset" or "Communication error code:503".

    Can you please notify if this an issue which will take time to fix or is the trial version not stable?
    I need to create few dashboards for a customer to showcase the capabilities, but this is definitely a letdown.
    Kindly provide an update on this issue.

    ------------------------------
    Prabhuraj Prabhuraj
    ------------------------------



  • 4.  RE: Communication error code:503

    Posted Mon January 21, 2019 12:15 PM
    I've also had the same problem.

    ------------------------------
    Diego Rodrigues
    ------------------------------



  • 5.  RE: Communication error code:503

    Posted Mon January 21, 2019 12:43 PM
    Hi all,  

    Yes, the problem has persistent from two weeks ago! Unfortunately we can't show the features of the product with customers or new opportunities of business.

    Regards!

    ------------------------------
    Jorge Daniel Anguiano Morales
    CEO
    TI SENCEI - Soluciones en la Nube - Capacitación e Implementación
    Querétaro QUE
    Mobile
    ------------------------------



  • 6.  RE: Communication error code:503

    Posted Mon January 21, 2019 05:01 PM

    Hi,

    Thanks for posting to the community and making us aware of the issue. Our team is actively investigating a root cause and working to resolve the issue. 

    Thank you,




    ------------------------------
    Sami El Cheikh
    Offering Manager
    IBM Cognos Analytics
    ------------------------------



  • 7.  RE: Communication error code:503

    Posted Mon January 21, 2019 05:53 PM
    Hi SAMI,

    Thanks, this problem has been presented since two weeks. I hope the problem will fix.

    Regards!

    ------------------------------
    Jorge Daniel Anguiano Morales
    CEO
    TI SENCEI - Soluciones en la Nube - Capacitación e Implementación
    Querétaro QUE
    Mobile
    ------------------------------



  • 8.  RE: Communication error code:503

    Posted Tue January 22, 2019 07:34 AM
    Hi Sami,

    Thanks for the information.

    Regards,

    ------------------------------
    Diego Rodrigues
    Technical Support Specialist
    São Paulo - Brazil
    ------------------------------



  • 9.  RE: Communication error code:503

    Posted Tue January 29, 2019 04:16 PM
    Hi everyone,

    Thank you for your patience, we believe we have identified and applied a fix for the major issues affecting the Cognos Analytics 11.1 trial. Please let us know if you are experiencing further performance issues.

    ------------------------------
    Sami El Cheikh
    Offering Manager
    IBM Cognos Analytics
    ------------------------------



  • 10.  RE: Communication error code:503

    Posted Tue January 29, 2019 04:51 PM
    Hi SAMI,

    In this moment I had tested my visualizations and dashboards. That is working correct!!!

    : )

    Thanks in advance!
    LIA Jorge Anguiano
    CEO TI SENCEI

    ------------------------------
    Jorge Daniel Anguiano Morales
    CEO
    TI SENCEI - Soluciones en la Nube - Capacitación e Implementación
    Querétaro QUE
    Mobile
    ------------------------------



  • 11.  RE: Communication error code:503

    Posted Wed January 30, 2019 10:03 AM
    Thanks so much, Sami! I'm no longer seeing the error and can see all my visuals.

    ------------------------------
    Cindy Berry
    ------------------------------



  • 12.  RE: Communication error code:503

    Posted Wed January 30, 2019 10:26 AM
    Just so you know, the errror Http code: 503 is back!​

    ------------------------------
    Roman Repin
    ------------------------------



  • 13.  RE: Communication error code:503

    Posted Wed January 30, 2019 10:43 AM
    @Roman Repin

    Thanks for posting to the community. Where are you seeing this error? I'm testing it out briefly and it seems to be working fine on my end.

    Please describe the issue in detail and add any relevant screenshots so we can investigate this further. 

    Thanks,​

    ------------------------------
    Sami El Cheikh
    Offering Manager
    IBM Cognos Analytics
    ------------------------------



  • 14.  RE: Communication error code:503

    Posted Thu January 31, 2019 05:02 AM
    @SAMI EL CHEIKH
    Yesterday I got the same error in several sample Dashboards as screenshot posted by Cindy Berry.
    Today all sample Dashboards works fine.



    ------------------------------
    Roman Repin
    ------------------------------



  • 15.  RE: Communication error code:503

    Posted Mon February 11, 2019 04:02 AM
    Thanks for the information

    ------------------------------
    Leading Bridge
    ------------------------------



  • 16.  RE: Communication error code:503

    Posted Thu March 07, 2019 02:35 AM
    As of today, we've got the same issue when using dashboards or data explaration, we've got the 11.1R1 version. Any news regarding this issue?

    ------------------------------
    Emilio de la Cuesta
    ------------------------------



  • 17.  RE: Communication error code:503

    Posted Thu March 07, 2019 10:09 AM
    Edited by Jenifer Broughton Thu March 07, 2019 10:12 AM
    I wonder if this is related to same issue I am having, but I am not using a Trial version.  We have Cognos Analytics version 11.0.11.

    I receive several different message, one is the same as this post "Can't read the dataset..."and also​ "Unable to establish a metadata connection to the data source (followed by a bunch of letters and numbers) then ending with _sessionTemp12HTTP/1.1 400 Bad Request."

    The errors seem to be random in my environment. 
     I am aware of 2 changes that were made on the server, that has helped SOMEWHAT, but it has NOT resolved the problem.

    • implemented an IBM recommended string of code into the Query Service XML. This was the change that corrected the dashboard related issues.
    • updated the IIS settings for Maximum URL Length and Maximum Query String. While not related to dashboards, we applied the changes based upon previous IBM communications.


    ------------------------------
    Jenifer Broughton
    ------------------------------



  • 18.  RE: Communication error code:503

    Posted Thu March 07, 2019 11:01 AM
    ​I do want to add one other thought.

    In researching the issue on dashboard errors, I found this:

    PI85117: ALPHABETICAL ORDER OF DATA ITEMS IN FM FOR DQM PACKAGE IN IMPORTVIEW AFFECTING DASHBOARD FILTER BEHAVIOR AND CAUSING ERROR

    I did have a sort applied to an item in my dashboard.  I removed the sort and thus far in my testing I am having positive results.

    ------------------------------
    Jenifer Broughton
    ------------------------------



  • 19.  RE: Communication error code:503

    Posted Thu March 07, 2019 01:59 PM

    The message:
    "Unable to establish a metadata connection to the data source (followed by a bunch of letters and numbers) then ending with _sessionTemp12HTTP/1.1 400 Bad Request."

    I've seen this message when editing a model or dashboard and then leaving that session idle for a while. The name of the data source, is the id of the model/dashboard-embedded-model in the user's temporary session on the server. These temporary models get cleaned up and the client needs to resend it before doing a query. A work around is to make a small change to the model/embedded model (e.g. change a label) and then things work again. 



    ------------------------------
    HENK CAZEMIER
    ------------------------------



  • 20.  RE: Communication error code:503

    Posted Fri March 08, 2019 06:27 AM
    Hi Henk,

    That is good information to know.  I am actually getting this error at times when I am working in the dashboard.  One example is when I go from one tab to another tab,​ I will see this error message now (after removing the sort on data item) usually for a few seconds then the graph appears.  Do you think there is a setting that needs modified?  We want to roll dashboards out to the CEO but we need to correct this issue before doing so.  Thanks!!!

    ------------------------------
    Jenifer Broughton
    ------------------------------



  • 21.  RE: Communication error code:503

    Posted Fri March 08, 2019 02:34 PM

    I've asked around and get some different opinions on what might be going on.
    Would you be able to get some details about the error message ?
    In the browser, open up a console window. For Chrome or IE you can do this hitting the F12 key.
    In the console look for the <Network> tab.
    When the error occurs again, you'll see an entry with a code 400.
    Select that message and look in the response for some detailed error codes/messages.



    ------------------------------
    HENK CAZEMIER
    ------------------------------



  • 22.  RE: Communication error code:503

    Posted Fri March 08, 2019 02:37 PM
    Hi there,

    Yes, absolutely!  I will supply the details when this occurs again.

    Thanks again!​

    ------------------------------
    Jenifer Broughton
    ------------------------------



  • 23.  RE: Communication error code:503

    Posted Fri March 08, 2019 02:52 PM
    Edited by Jenifer Broughton Fri March 08, 2019 03:31 PM
    I was able to get it to occur.  However,  on the network tab the 400 bad request doesn't appear even though the viz has the error message in the widget.​  There are error type messages on the 'console' tab.
    There is a '500 internal server error' that appears earlier in the list which states "errors":[{"code":"XQE-MD-0007","details":"XQE-MD-0007.

    I had it happed on 2 separate graphs.
    First Warning/Error that appear happened together:
    ERROR States:  "At Anonymous function (then the url).. An error occurred while waiting for the data to be ready [ojects Arguments] [object] [object]"
    Expanding the error message I see the following details:
    An error occured while waiting for the data to be ready"
    callee<Permission denied>
    caller<Permission denied>

    WARNING States:  Missing translation for key: "Unable to establish a metadata connection to data source …..._sessionTemp12HTTP/1.1 400 Bad Request."

    But when the error happens on a second viz I see this on the console tab:
    WARNING States:  WARNING: Missing translation for key: "Color Palette"
    There is no Error message, but the graph still has the error message within the widget and has not populated yet.

    I hope this is helpful..


    ------------------------------
    Jenifer Broughton
    ------------------------------



  • 24.  RE: Communication error code:503

    Posted Fri March 08, 2019 04:23 PM
    Which version of Cognos are you using, could you do a screen cap like:



    ------------------------------
    HENK CAZEMIER
    ------------------------------