Cognos Analytics

Expand all | Collapse all

Total % is not giving the correct number

  • 1.  Total % is not giving the correct number

    Posted Wed December 18, 2019 12:04 AM
    Hi All

    While applying the summary total in List , not getting the correct percentage value .



    ------------------------------
    MONA KEDIA
    ------------------------------


  • 2.  RE: Total % is not giving the correct number

    Posted Wed December 18, 2019 03:39 AM
    Hi Mona

    If the percentage value calculated in the report and you are using the Total you will get the total of all the values as shown. If you instead use the Default summary you should get the correct value.

    You could also change the Summary property of the list cell to Aggregate instead of Total





    ------------------------------
    Jesper Bjerre
    ------------------------------



  • 3.  RE: Total % is not giving the correct number

    Posted Tue April 06, 2021 12:50 PM
    Thanks Jesper, helped me in the same situation.

    ------------------------------
    Dagur Egonsson
    ------------------------------



  • 4.  RE: Total % is not giving the correct number

    Posted Thu December 19, 2019 05:23 PM
    Hi Mona,

    I think ​you are using automatic summary fields and those may not work for percentage values. I would recommend you to create a separate data items in your query which calculates the percentage for all values and replace automatic summary data item with the new calculated one.

    Hope this works!

    Hemal

    ------------------------------
    Hemal Patel
    ------------------------------



  • 5.  RE: Total % is not giving the correct number

    Posted Tue April 06, 2021 01:44 PM
    Hi , if i understand correct just divide your value as per screen


    ------------------------------
    Hashim Raza
    ------------------------------