Cognos Analytics

Expand all | Collapse all

Issue with PresentationService - millions of failed requests

  • 1.  Issue with PresentationService - millions of failed requests

    Posted 25 days ago
    Since 2 1/2 year do we have a specific issue with the PresentationService.
    Cognos produces a non-stop stream of failed request on it.
    This goes on at a rate of 300.000 failed request per hour! Today it passed the total of 41 million, in just 5 days.
    Resulting in het constant 100% CPU, the only way to stop it is to restart the servers.
    This issue returns several times a year, on april 6 we migrated to 11.1 R7 and this is the first time, this issue appears in this new environment.

    Is there anybody who has (had) the same issue?

    We have pushed IBM for over 6 month, to look into it, but they only repeated the 'IBM standard requests'  - so this was a dead end street in the end

    The only thing that i found out, is that this issue coincides with a specific event. (IBM didn't want to follow this lead)

    Above is the image of our PresentationService , and the failed request.
    I can trace back the start of the issue, by substracting the 'Respons Time high Watermark' from the Current time,
    for this i get a starting point at around 13-april-2021 15:56,56  

     

    In the cogaudit.log I find this entry:
    2021-04-13 15:56:55.983  Failure    RSVP Audit.RTUsage.RSVP Response ReportService       RSV-SRV-0066 A soap fault has been returned 
    >Spot on: I find EVERY time the EXACT SAME thing happening:

    The SESSIONID from the Failure, above, is a Session, which already has expired, hours ago

    2021-04-13 10:50:38.887  login /   2021-04-13 13:11:18.777  expired  (from the same log-file)

    Our sessions expire after 2 hours of inactivity, i can see that the last activity of this user was at 2021-04-13 11:06,59 and that the session expired correctly 2 hours later.

    But I don't have a clue why there is suddenly (3 hours after expiring time) a kind of 'revival' of this session.

    We do have this issue often, but only on specific occasions this leads to the problem with PresentationService.failed requests

    It would be very welcome if someone could come with any idea what is happening and how to solve it.

    Paul Peeters



    ------------------------------
    Paul Peeters
    ------------------------------


  • 2.  RE: Issue with PresentationService - millions of failed requests

    Posted 25 days ago
    Edited by STEFAN VERMEULEN 25 days ago

    Can you describe your environment?
    Single server, multi server, user load, tier division etc.
    Also number of cores and memory for each server, how much assigned to the Liberty Profile JVM for each?

    Reason i ask, is because the presentation service runs on the JVM from the Dispatcher tier, where as the confused user sessions run in the JVM on the Content Manager tier. 

    ------------------------------
    STEFAN VERMEULEN
    ------------------------------