Maximo

 View Only
  • 1.  Mas 8 pipelines SLS deployment error

    Posted Fri June 14, 2024 01:35 PM
      |   view attached

    Hi, using ansible play book to deploy mas and sls isn't completing. says failed to gather info about truststore not being ready.

    OCP version 4.13.43

    Kubeversion v1.26.15+4818370

    lastTransitionTime: '2024-06-13T14:44:30Z'
            message: |-
              Failed to gather information about Truststore(s) even after waiting for 120 seconds
              TruststoreNotReady: SLS truststore (sls-truststore) is not ready. Timed out after 2 minutes.
            reason: Failed
            status: 'True'

    TASK [ibm.mas_devops.sls : Wait for LicenseService to be ready (60s delay)] ****
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (20 retries left).
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (19 retries left).
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (18 retries left).
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (17 retries left).
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (16 retries left).
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (15 retries left).
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (14 retries left).
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (13 retries left).
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (12 retries left).
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (11 retries left).
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (10 retries left).
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (9 retries left).
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (8 retries left).
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (7 retries left).
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (6 retries left).
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (5 retries left).
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (4 retries left).
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (3 retries left).
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (2 retries left).
    FAILED - RETRYING: [localhost]: Wait for LicenseService to be ready (60s delay) (1 retries left).
    fatal: [localhost]: FAILED! => changed=false 

    any help would be appreciated

    Thanks



    ------------------------------
    jay fah
    ------------------------------


  • 2.  RE: Mas 8 pipelines SLS deployment error

    IBM Champion
    Posted Mon June 17, 2024 02:37 AM

    Hi Jay,

    can You provide some more information about Your setup? which version of CLI are You using? which catalog? which MAS version are You trying to deploy?



    ------------------------------
    Witold Wierzchowski
    ------------------------------



  • 3.  RE: Mas 8 pipelines SLS deployment error

    Posted Mon June 17, 2024 10:36 AM

    We are experiencing the same issue as what was posted above. 

    We already have a cluster up and running and have never had it fail before on the pipeline.  But what I can tell you is that we are trying to setup the same except in another location.  Ran through the playbook accepting the defaults on the versions as this is really just repetition and adding to another location before our deployment project begins.

    Maybe some key differences is that in this cluster the differences are leveraging the same app points as our other cluster (running) and selecting production instead of the nonproduction option.  What we were looking to get from this is test if we have any differences in MAS / Manage availability when running an OpenShift update on nonproduction verse production.  Also to start exploring options on DR.

    Thanks,

    Kirk



    ------------------------------
    Kirk Youngbauer
    ------------------------------



  • 4.  RE: Mas 8 pipelines SLS deployment error

    Posted Mon June 17, 2024 10:45 AM
    Edited by jay fah Mon June 17, 2024 10:46 AM

    Hi, after troubleshooting for a while got it resolved. the coreidp pod was failing to find the secret "mas8-keys-ltpa"  triggering a re-run of the ltpa key generator pod (forgot the name) got the whole pipeline to eventually succeed. It then started failing on truststore timing out on verify-suite task, resolved that by deleting the truststores under IBM truststore manager and rerunning the pipeline again(quite exhausting). currently the new issue I got is not being able to access the admin dashboard getting a security error on firefox even though i have explicitly confirmed the security exception for *apps.x.x.x .

    FYI 

    mas-catalog-version v8-240430-amd64

    cli 9.4.0



    ------------------------------
    jay fah
    ------------------------------



  • 5.  RE: Mas 8 pipelines SLS deployment error

    Posted Mon June 17, 2024 10:30 AM

    Can you check LicenseService CR and what issue is seen in there?



    ------------------------------
    Srinivasa Reddy
    Melbourne
    469791409
    ------------------------------