Instana

  • 1.  Is anyone using the APM REST API?

    Posted Tue January 22, 2019 02:57 PM
    ​Is anyone using the Cloud APM v8 REST API?  I need to programmatically change the members of a resource group, based on status information collected in Omnibus.  I'm trying to acquire the OIDC token but whenever I run my request I get back an "NSS error -12263" message.

    I'm trying
    curl -tlsv1.2 -v -k -d "grant_type=password&client_id=rpapmui&client_secret=<decoded XOR value from clientSecrets.xml>&umin&password=apmpass&scope=opened" https://my_apm_host:8090/oidc/endpoint/OP/token

    and getting back
    * About to connect() to my_apm_host port 8090 (#0)
    *   Trying xx.yy.zz.aa... connected
    * Connected to my_apm_host (xx.yy.zz.aa) port 8090 (#0)
    * Initializing NSS with certpath: sql:/etc/pki/nssdb
    * warning: ignoring value of ssl.verifyhost
    * NSS error -12263
    * Closing connection #0
    * SSL connect error

    curl: (35) SSL connect error

    ------------------------------
    Joseph Howell
    ------------------------------


  • 2.  RE: Is anyone using the APM REST API?

    Posted Tue January 22, 2019 03:46 PM
    Are you using this procedure and followed all the steps?

    https://www.ibm.com/support/knowledgecenter/SSHLNR_8.1.4/com.ibm.pm.doc/install/admin_resourcegroup_api.htm
    Ibm remove preview
    View this on Ibm >


    Did you also review this link?

    https://developer.ibm.com/api/view/perfmgmt-prod:apm_basic:title-IBM_Cloud_Application_Performance_Management_API#doc

    ------------------------------
    Kirk Bixler
    IBM
    ------------------------------



  • 3.  RE: Is anyone using the APM REST API?

    Posted Wed January 23, 2019 08:18 AM
    ​Hi, Kirk.
    Yes, I'm following the instructions.  I am stuck at step 3, acquiring the token.  I have opened a case, just wanted to see if anyone in the group had words of wisdom.

    ------------------------------
    Joseph Howell
    ------------------------------



  • 4.  RE: Is anyone using the APM REST API?

    Posted Wed January 23, 2019 08:27 AM
    ​OK, I think I just found my problem.  Two dashes ("--") before "tlsv1.2".  I think I only had one before.  Now I'm getting "invalid_resource_owner_credential" errors.  Does that mean the secrets value is bad, or the userid/password combination is wrong?

    ------------------------------
    Joseph Howell
    ------------------------------



  • 5.  RE: Is anyone using the APM REST API?
    Best Answer

    Posted Wed January 23, 2019 08:36 AM
    ​Found the magic.  In our environment, we are integrated with Active Directory.  So, I can't use one of the built-in accounts like "apmadmin",  "smadmin", or the Websphere admin account.  The userid and password need to be (as documented) an account that can log in to the GUI.

    Thanks for the assist.  Moving on to the next adventure.....

    ------------------------------
    Joseph Howell
    ------------------------------