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SPSS Statistics and Open Source

Why leverage open-source in SPSS Statistics?
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What integrations are available to SPSS Statistics users? ¥
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How can a user integrate R/Python with SPSS Statistics? L
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SPSS Statistics
+

Open Source

A Powerful
Combination

ACADEMICS

Sociology research
professor of 15+ years

Extends syntax with R to
leverage open-source
statistical packages

Prefers SPSS Statistics to
an IDE for reproducibility
and built-in high quality
outputs

Creates Custom Dialog

Boxes to share with
students

BUSINESS

4

Analyst with no data
science background at a
small consulting firm

Utilizes Extension Hub to
incorporate functionality
from R/Python

Extensions look and feel
like any other statistical
package in SPSS Statistics
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Experienced quantitative
market researcher for a
large tech company

Develops open-source
based extensions to share
with analysts

Custom extensions
increase efficiency of
commonly run procedures




Programming with SPSS Statistics

IBM SPSS Statistics as a statistical software program contains a set of powerful programming
and extension capabilities that users familiar with R and Python can leverage.

Non-technical users also benefit by functionality added by those interested in extending the
value of the software. This includes:

» Create and deploy program extensions in R and Python

« Execute R and Python programs from within SPSS Statistics with BEGIN PROGRAM ... END
PROGRAM

« Driving SPSS Statistics from external R language or Python programs

« Scripting in Python (also in Basic on Windows)
» Execute scripts internally or externally

» Associate Autoscripts that execute when new output is generated



Execute Code from Command Syntax

Users can execute a Python or R language program
by embedding code within a BEGIN PROGRAM ...
END PROGRAM block in command syntax.

The command syntax can be run from the IBM
SPSS Statistics client or from the IBM SPSS
Statistics Batch Facility. *

Python and R code has access to the underlying
Statistics engine via exposed Statistics library
interfaces.

*The IBM SPSS Statistics Batch Facilityis a
separate executable provided with IBM SPSS
Statistics Server.

To embed Python 3
code within Statistics

To embed R language
code within Statistics

syntax, use: syntax, use:
BEGIN PROGRAM BEGIN PROGRAMR ...
PYTHONS3 ... END END PROGRAM.
PROGRAM.
BEGIN PROGRAM [{PYTHON3- 1%].

iR 5

programming language-specific statements

END PROGRAM.




Driving SPSS Statistics from External Programs

In this mode, you still have access to all of the functions in the Python and R Integration
Packages for IBM SPSS Statistics, but you can develop and test your programs with the
development environment of your choice.

SPSS Statistics ships with automatically installed versions of Python 3 and the R language.
These are part of a virtual environment that each user on a given machine has exclusive access
to.

« Python programs make use of the interfaces exposed by the Python spss and the
SpssClient modules. Start by a call to the spss.StartSPSS function.

« Users can utilize the built-in IDLE Python editor or use their own preferred editor.

« R programs include the spssstatistics library, followed by a call to the
spsspkg.StartStatistics function.



Running SPSS Statistics from Python

Users can drive the SPSS
Statistics program from
their preferred Python
development environment.

The image at right shows
the Wing Python
development environment
being used to drive
Statistics via the Statistics
Python libraries.

4 » CasingDict - (bottom) -

1039 k1 = key.lower()

1040 dict. delitem_ (self, k1)

1041 _ del self.arigcase[k1]

1042 = else:

1043 dict. delitem_ (self, key)

1044

1045 = class (object):

1046 = """A Python dictionary indexed by variable name for use with the SPSS Variable Dictiona
1047

1048 The Python dictionary does not contain SPSS dictionary properties other than name and i
1049 Other variable properties are retrieved dynamically when requested.

la5e

1051 Unlike the SPSS dictionary, variable names in this class are case sensitive (except for
_\:n Files| 5earch « » " Exceptions Debug Console Debug 1/0 Watch Modules| Python Shell Messages OS Commands

Search: |eval -

[ Case siv| Whole [ ] In Sele

Previol + Nex Iption
1>>>
255>
355>

& Line 1044 Col O - [User]

Commands will be debugged. Use arrow keys for history.

Python 3.9.1 (tags/v3.9.1:1le5d33e, Dec 7 2020, 17:88:21) [MSC v.1927 6
Type "help™, "copyright”, "credits™ or "license" for more information.
import spss, spssaux
spssaux.OpenDataFile("c:/spss28/samples/english/employee data.sav")
spss.Submit]

F: StartDataStep 4

F: StartProcedure

F: StartsPss

F: StopSPSS

¢ StrError

=@ 5ys

c: TextBlock n

c: Variable

c: Variablelist v



Running SPSS Statistics from R

Users can run an R
language development
environment to drive
SPSS Statistics from
their favorite R language
IDE.

The image at right
shows SPSS Statistics
being driven by the
RStudio R language
development
environment.

R version 4.0.5 (2021-03-31) —- "shake and Throw"
copyright (C) 2021 The R rFoundation for statistical computing
platform: x86_64-wb4-mingw32/x64 (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type ‘license(}" or "licence()" for distribution details.

natural language support but running in an english Tocale

R is a collaborative project with many contributors.
Type ‘contributors()’ for more information and
"citation()" on how to cite R or R packages in publications.

Type ‘demo()” for some demos, *help()® for on-Tine help, or
"help.start()” for an HML browser interface to help.
Type ‘q()" to quit R.

* project 'C:/users/jkpec/AppbData/Roaming/IBM/SPSs statistics/28/R40° loaded. [renv
0.13.2]

> library(spssstatistics)

> spsspkg. startstatistics ()

> spsspkg.version()

$platform

[1] "xB6_64-w64-mingw32"

$arch
[1] "x86_64™
Sos

[1]1 “mingw32™

§system

[1] "xB6_64, mingw32"

$version.string
version

"28.0.0.0"

>

-waom
R: An interface to embed R in SPSS Statistics - | Find in Topic

An interface to embed R in SPSS Statistics

Documentation for package ‘spssstatistics’ version 28.0.0.0

= DESCRIPTION file.

Help Pages

BCEHIST
spss-package An interface to use R with IBM SPSS Statistics
BasePivotTable Class for IBM SPSS Statistics pivot tables

BasePivoiTable-class
BasePivotTable. Append-method

Class for IBM SPSS Statistics pivot tables
Class for IBM SPSS Statistics pivot tables

BascPivolTable.C oomoles:  (jaqq for IBM SPSS Statistics pivet tables
method

BasePivotTable Di il notes- S

meth Class for IBM SPSS Statistics pivot tables

BasePivoiTable.Footnotes-method Class for IBM SPSS Statistics pivot tables
BasePivoiTable GetCellValue-method  Class for IBM SPSS Statistics pivot tables

BasePivotTable GetDefaultf ormatSpec: (|5 for IBM SPSS Statistics pivot tables

method

BasePivotTable HideTitle-method Class for IBM SPSS Statistics pivot tables
BasePivoiTable.Insert-method Class for IBM SPSS Statistics pivot tables
e L e e D i e Class for IBM SPSS Statistics pivot tables

BasePivotTable.SetCategories-method Class for IBM SPSS Statistics pivot tables
BasePhvolTable SelCellsByColumi:  glags for IBM SPSS Statistics pivat tables
BasePivotTable SetCellsByRow-method Class for IBM SPSS Statistics pivot tables
BasePivotTable SetCellValue-method ~ Class for IBM SPSS Statistics pivot tables

BasePivolTable SeDefaullFomalSpec: o for IBM SPSS Statistics pivat tables

BasePivofTable TitleF ootnotes-method Class for IBM SPSS Statistics pivot tables




The Scripting Facility in SPSS Statistics

The scripting facility allows you to Default Script Language
automate tasks, including: » Determines the script editor that is launched

. Opening and saving data files. when new scripts are created .

« Exporting charts as graphic files in a + Italso specifies the default language whose
variety of formats executable will be used to run autoscripts.

« Customizing output in the Viewer. « On Windows, the default script language is
Basic.

« Creating and executing autoscripts
_ * Change the default language from the Scripts
« Startup scripts that execute when tab in the Options dialog.

SPSS Statistics starts



Scripting in Python (and in BASIC on Windows)

Run from SPSS Statistics.

* Run from Utilities>Run Script or from the Python script editor which is launched when
opening a Python file (.py) from File>Open>Script.

« Operate on the SPSS Statistics client that launched the editor

* Use the SCRIPT syntax command to execute scripts from within or outside SPSS Statistics

Run from an External Python Process.
« A Python IDE that is not launched from SPSS Statistics, or the Python interpreter.
« Attempts to start or connect to an existing SPSS Statistics client.

« By default, the newly started Data Editor and Viewer are invisible for the new client. You can
choose to make them visible or work in invisible mode with datasets and output documents.

10



Autoscripts

Autoscripts are scripts that run automatically
when triggered by the creation of specific
types of output from selected procedures.

« Events: New tables, notes, or warnings
» Associated from Output or from Options
Autoscripts in SPSS Statistics Options

« Select the default autoscript language

« Manage script associations

» Create a Base Autoscript that applies to
all new output

Options

r_ ‘.
4 Viewer Data Currency Output Charts Pivat Tables File Locations E\ ts )Mu\tip\e Imputations Syntax Editor Privacy 3

Default script language: | python3 [ Select the language to use when new scripts are created.

WSe... Language:  Python3

AIM

Alscal
Alter Type
ANACOR

a script in the Objects and Scripts grid.

11



R and Python Extensions

Among the most powerful features in SPSS Statistics is the ability to add functionality to the

program via Extensions.

SPSS Statistics ships with a variety of extensions that are provided internally.

With SPSS Statistics Extensions one can:

Customize SPSS Statistics by adding R and Python extensions that are driven by syntax
Access datasets from the central system

Incorporate open-source algorithms

Generate standardized output

Modify existing output

Design and deploy custom user interfaces that emit syntax

Share and deploy extensions for other SPSS Statistics users

12



R and Python Extensions (continued)

Users install and uninstall extensions via the
Extension Hub:

» An interface for searching for,
downloading, and installing public
extensions

 Accessed from Extensions > Extension
Hub

 Local extensions can be installed from
Extensions > Install Local Extension
Bundle

Refine by
Search

Category
Analysis
Data manipulation
Geospatial
Presentation
Utility
Visualization
Watson

Language
SPSS Statistics Syntax
Java R
Python 2 Python 3

Developed by
Business Partner
Community
IBM

State
Installed

Not installed
Update available

Apply

Sort by:

[E]
y

Extension Hub

Explore Installed  Settings

Most recent )

STATS_POWERSIM
Latest Version: 1,0.0 Date: 2021-11-11

Performs simulations of various parameters for the POWER procedures.

More info...

SPSS Statistics Syntax  Presentation

Fluctuation Plot
Latest Version: 1.0.0 Date: 2021-11-2

Plot of two categorical variables.

More info...

SPSS Statistics Syntax  Utility

STATS FLEISS KAPPA
Latest Version: 2.0.1 Date: 2021-10-14

‘ M Compute Fleiss Multi-Rater Kappa Statistics

@ Extensions to get: 0 Updates to get: 0 Extensions to uninstall; 0

Select all

Prerequisites: J

Get extension

Get extension

Prerequisites: \/

Get extension

Note: R packages required by the selected extensions will be downloaded over the Internet if possible.

Cancel
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R and Python Extensions (continued)

Users create specialized user interfaces for

Open | 3 Open Installed | [] Preview 4 Save Wy install

extensions via the Custom Dialog Builder:

[ source List Group Indicator Options...
v & Varisbie ® Tips
arlak 'OPTIONS %Xsampling%% %Xminimizememory¥% %%shuffleX¥% %¥%seed¥%%

X Predictc
H Field Chooser Variable e DELETE VARIABLES %(matchgroup)s.

« Drag and drop controls onto the el i AR

DELETE VARIABLES %(matchgroup)s.
DATASET COPY ¥¥outputdatase

of] Target List

. B Check Box DATASET ACTIVATE %¥outputdatasetsé.
production canvas B ot
; 9
List Box Name for Propensity Vari... DATASET ACTIVATE %(tempdsname)s.
o DATASET ACTIVATE %¥outputdataset.
[ Text control This procedure runs a lo. ADD FILES [FILE=* /FILE=%(tempdsname)s.
. ] . Match Tolerance EXECUTE.
« Associate controls with the properties

ER Date control At Shn L9l of Case D

spss.Submit(fuzzycmd)
|| Var end program

that drive an extension

Ab Static Text

Dialog Properties
i color Picker Property
Dialog Name PSM

F Table control

° G .t t h t f d N Menu Location Data/Propensity Score Matching... \dentifier _ Title Syntax
enerate the syntax tor ariving emGrow PropensySce Matching B el -

E Radio Group Help File [private var/folders/24 /bq6m703x0td5 ha8hwp29rdqv Group fdi.. T s {306ThisVah
. id Case ID: t %XT hisValue¥d%
exte n S I o n S 17 Check Box Group | Web Deployment Properties Vatch b - Vel
Modeless True ‘ Variable f... DRAWPOOLSIZE = %XThisValue¥%

File Browser
Sampling adio SAMPLEWITHREPLACEMENT =%%Thi...

Tab imiz. Maximize ... C Box MINIMIZEMEMORY = TRUE
= 0!
*Syntax displayed for Check Box and Check Box Group controls is

b4 s
& Sub-dialog Button Checked Syntax

« Live preview and syntax generation
* Deploy or save directly

* No GUI programming required!
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SPSS Statistics Demo



Resources

Watch all Tech talks:
GradPack (Students / Faculty):
Take the no cost

Interactive Product Tour:

Join the SPSS Statistics Community:

Use cases:
Blog:
Extensions:

Solution brief:

16


https://ibm.biz/spsstechtalk
https://www.ibm.com/us-en/marketplace/spss-statistics-gradpack/details
https://www.ibm.com/account/reg/signup?formid=urx-19774
https://www.ibm.com/cloud/garage/dte/producttour/explore-and-analyze-employee-data
https://www.ibm.com/community/spss-statistics
https://www.ibm.com/analytics/statistical-software-industry-use-cases/
https://www.ibm.com/blogs/journey-to-ai/2021/05/a-learning-guide-to-ibm-spss-statistics-get-the-most-out-of-your-statistical-analysis/
https://community.ibm.com/HigherLogic/System/DownloadDocumentFile.ashx?DocumentFileKey=df2d8ede-6c1b-3209-35d0-dac4f0810b66
https://www.ibm.com/downloads/cas/YB9DVOAR

Next steps

Purchase SPSS Statistics Try the Free Edition

g ibm.com/spssstatistics ibm.biz/SPSSStats
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Trademarks and notes
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in the United States, other countries, or both. If these and other IBM trademarked terms are marked on their first occurrencein
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countries. A current list of IBM trademarks is available on the Web at “ " at
www.ibm.com/legal/copytrade.shtml.

Other company, product, and service names may be trademarks or service marks of others.

Referencesin this publicationto IBM products or services do not imply that IBM intends to make them available in all countriesin
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